summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2020-05-28 06:43:13 -0600
committerChristoph Junghans <junghans@gentoo.org>2020-05-28 06:43:59 -0600
commit7d3b41b7a951834884f113894d86642a86293c54 (patch)
tree0da0cbc0ccc1c740b8c137bc976267afc47d3b6a /sys-cluster/libcircle/libcircle-0.3.0.ebuild
parentx11-misc/shared-mime-info: s390 stable wrt bug #725658 (diff)
downloadgentoo-7d3b41b7a951834884f113894d86642a86293c54.tar.gz
gentoo-7d3b41b7a951834884f113894d86642a86293c54.tar.bz2
gentoo-7d3b41b7a951834884f113894d86642a86293c54.zip
sys-cluster/libcircle: version bump
Closes: https://bugs.gentoo.org/725694 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sys-cluster/libcircle/libcircle-0.3.0.ebuild')
-rw-r--r--sys-cluster/libcircle/libcircle-0.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-cluster/libcircle/libcircle-0.3.0.ebuild b/sys-cluster/libcircle/libcircle-0.3.0.ebuild
new file mode 100644
index 000000000000..1193a7cab64f
--- /dev/null
+++ b/sys-cluster/libcircle/libcircle-0.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hpc/${PN}/releases/download/v0.3/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+fi
+
+DESCRIPTION="API for distributing embarrassingly parallel workloads using self-stabilization"
+HOMEPAGE="https://github.com/hpc/libcircle"
+
+SLOT="0"
+LICENSE="BSD"
+IUSE="doc static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/mpi"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check )"
+
+src_configure() {
+ econf \
+ $(use_enable doc doxygen) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${S}/doc/html/." )
+ default
+}