summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/libdlm/libdlm-3.1.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/libdlm/libdlm-3.1.5.ebuild')
-rw-r--r--sys-cluster/libdlm/libdlm-3.1.5.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-cluster/libdlm/libdlm-3.1.5.ebuild b/sys-cluster/libdlm/libdlm-3.1.5.ebuild
new file mode 100644
index 000000000000..66fc618a03e5
--- /dev/null
+++ b/sys-cluster/libdlm/libdlm-3.1.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib toolchain-funcs versionator
+
+CLUSTER_RELEASE="${PV}"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+MAJ_PV="$(get_major_version)"
+MIN_PV="$(get_version_component_range 2-3)"
+
+DESCRIPTION="General-purpose Distributed Lock Manager Library"
+HOMEPAGE="https://fedorahosted.org/cluster/wiki/HomePage"
+SRC_URI="https://fedorahosted.org/releases/c/l/cluster/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ !sys-cluster/dlm-headers
+ !sys-cluster/dlm-kernel
+ !sys-cluster/dlm-lib"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.24"
+
+S=${WORKDIR}/${MY_P}/dlm
+
+src_configure() {
+ cd "${WORKDIR}/${MY_P}"
+ ./configure \
+ --cc=$(tc-getCC) \
+ --cflags="-Wall" \
+ --libdir=/usr/$(get_libdir) \
+ --disable_kernel_check \
+ --kernel_src=/usr/ \
+ --somajor="$MAJ_PV" \
+ --sominor="$MIN_PV" \
+ --dlmlibdir=/usr/$(get_libdir) \
+ --dlmincdir=/usr/include \
+ --dlmcontrollibdir=/usr/$(get_libdir) \
+ --dlmcontrolincdir=/usr/include \
+ || die "configure problem"
+}
+
+src_compile() {
+ for i in libdlm libdlmcontrol; do
+ emake -C ${i}
+ done
+}
+
+src_install() {
+ for i in libdlm libdlmcontrol; do
+ emake DESTDIR="${D}" -C ${i} install
+ done
+ use static-libs || rm -f "${D}"/usr/lib*/*.a
+ doman man/libdlm.3
+ dodoc doc/{libdlm.txt,example.c,user-dlm-overview.txt}
+}