summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-08-10 11:07:58 -0600
committerDavid Seifert <soap@gentoo.org>2016-08-11 09:54:46 +0200
commitade38d7a718260d0a2600a2421ea5959a12b4f43 (patch)
treeb839ed9d56b28d69eccca1ba423fdc0ac4bdfe98 /sys-cluster/mpich
parentsys-cluster/openmpi: added multilib version (diff)
downloadgentoo-ade38d7a718260d0a2600a2421ea5959a12b4f43.tar.gz
gentoo-ade38d7a718260d0a2600a2421ea5959a12b4f43.tar.bz2
gentoo-ade38d7a718260d0a2600a2421ea5959a12b4f43.zip
sys-cluster/mpich: add multilib version
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2062 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-cluster/mpich')
-rw-r--r--sys-cluster/mpich/mpich-3.2-r1.ebuild114
1 files changed, 114 insertions, 0 deletions
diff --git a/sys-cluster/mpich/mpich-3.2-r1.ebuild b/sys-cluster/mpich/mpich-3.2-r1.ebuild
new file mode 100644
index 000000000000..382b2caba7a8
--- /dev/null
+++ b/sys-cluster/mpich/mpich-3.2-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD="77 90"
+
+inherit fortran-2 multilib-minimal
+
+MY_PV=${PV/_/}
+DESCRIPTION="A high performance and portable MPI implementation"
+HOMEPAGE="http://www.mpich.org/"
+SRC_URI="http://www.mpich.org/static/downloads/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="mpich"
+KEYWORDS=""
+IUSE="+cxx doc fortran mpi-threads romio threads"
+REQUIRED_USE="mpi-threads? ( threads )"
+
+COMMON_DEPEND="
+ >=dev-libs/libaio-0.3.109-r5[${MULTILIB_USEDEP}]
+ >=sys-apps/hwloc-1.10.0-r2[${MULTILIB_USEDEP}]
+ romio? ( net-fs/nfs-utils )"
+
+DEPEND="${COMMON_DEPEND}
+ dev-lang/perl
+ sys-devel/libtool"
+
+RDEPEND="${COMMON_DEPEND}
+ !sys-cluster/mpich2
+ !sys-cluster/openmpi"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/mpicxx.h
+ /usr/include/mpi.h
+ /usr/include/opa_config.h
+)
+
+src_prepare() {
+ default
+
+ # Using MPICHLIB_LDFLAGS doesn't seem to fully work.
+ sed -i 's| *@WRAPPER_LDFLAGS@ *||' \
+ src/packaging/pkgconfig/mpich.pc.in \
+ src/env/*.in \
+ || die
+}
+
+multilib_src_configure() {
+ # The configure statements can be somewhat confusing, as they
+ # don't all show up in the top level configure, however, they
+ # are picked up in the children directories.
+
+ export MPICHLIB_CFLAGS="${CFLAGS}"
+ export MPICHLIB_CPPFLAGS="${CPPFLAGS}"
+ export MPICHLIB_CXXFLAGS="${CXXFLAGS}"
+ export MPICHLIB_FFLAGS="${FFLAGS}"
+ export MPICHLIB_FCFLAGS="${FCFLAGS}"
+ export MPICHLIB_LDFLAGS="${LDFLAGS}"
+ unset CFLAGS CPPFLAGS CXXFLAGS FFLAGS FCFLAGS LDFLAGS
+
+ ECONF_SOURCE=${S} econf \
+ --enable-shared \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ --with-hwloc-prefix="${EPREFIX}/usr" \
+ --enable-threads=$(usex mpi-threads runtime single) \
+ --with-thread-package=$(usex threads pthreads none) \
+ --with-pm=hydra \
+ --disable-fast \
+ --enable-versioning \
+ $(use_enable romio) \
+ $(use_enable cxx) \
+ $(multilib_native_use_enable fortran fortran all)
+}
+
+multilib_src_test() {
+ emake -j1 check
+}
+
+multilib_src_install() {
+ default
+
+ # fortran header cannot be wrapped (bug #540508), workaround part 1
+ if multilib_is_native_abi && use fortran; then
+ mkdir "${T}"/fortran || die
+ mv "${ED}"usr/include/mpif* "${T}"/fortran || die
+ mv "${ED}"usr/include/*.mod "${T}"/fortran || die
+ else
+ # some fortran files get installed unconditionally
+ rm "${ED}"usr/include/mpif* "${ED}"usr/include/*.mod || die
+ fi
+}
+
+multilib_src_install_all() {
+ # fortran header cannot be wrapped (bug #540508), workaround part 2
+ if use fortran; then
+ mv "${T}"/fortran/* "${ED}"usr/include || die
+ fi
+
+ einstalldocs
+ newdoc src/pm/hydra/README README.hydra
+ if use romio; then
+ newdoc src/mpi/romio/README README.romio
+ fi
+
+ if ! use doc; then
+ rm -rf "${ED}"usr/share/doc/${PF}/www* || die
+ fi
+}