summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-03-22 17:33:27 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-03-22 17:34:13 +0300
commit7753ef2ff664ef275563d0c02f9514dba95d7d87 (patch)
tree8a7202a9e0c0a936b26605eb7a4d99b03132a61c /sys-cluster/openmpi/openmpi-1.4.5.ebuild
parentapp-emulation/fs-uae-launcher: Version bump to 3.0.3, drop old 3.0.2 (diff)
downloadgentoo-7753ef2ff664ef275563d0c02f9514dba95d7d87.tar.gz
gentoo-7753ef2ff664ef275563d0c02f9514dba95d7d87.tar.bz2
gentoo-7753ef2ff664ef275563d0c02f9514dba95d7d87.zip
sys-cluster/openmpi: migrate 1.4.5 to EAPI=7
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-cluster/openmpi/openmpi-1.4.5.ebuild')
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.5.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.4.5.ebuild b/sys-cluster/openmpi/openmpi-1.4.5.ebuild
index 06dc029d76c8..5d2d9e0e1e98 100644
--- a/sys-cluster/openmpi/openmpi-1.4.5.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.5.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
FORTRAN_NEEDED=fortran
-inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
+inherit fortran-2 flag-o-matic toolchain-funcs
MY_P=${P/-mpi}
@@ -50,6 +50,7 @@ pkg_setup() {
}
src_prepare() {
+ default
# Necessary for scalibility, see
# http://www.open-mpi.org/community/lists/users/2008/09/6514.php
if use threads; then
@@ -92,7 +93,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
dodoc README AUTHORS NEWS VERSION
}