summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-18 18:18:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-18 18:18:23 -0500
commitbc515e4a6ffd4e06bd01f2362f30e8963379789e (patch)
treecf8019616f391b9cb2ecb4e07c909b561d270b18 /sys-cluster/openstack-meta/openstack-meta-2020.2.0.ebuild
parentsys-cluster/heat: VICTORIA (diff)
downloadgentoo-bc515e4a6ffd4e06bd01f2362f30e8963379789e.tar.gz
gentoo-bc515e4a6ffd4e06bd01f2362f30e8963379789e.tar.bz2
gentoo-bc515e4a6ffd4e06bd01f2362f30e8963379789e.zip
sys-cluster/openstack-meta: VICTORIA
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-cluster/openstack-meta/openstack-meta-2020.2.0.ebuild')
-rw-r--r--sys-cluster/openstack-meta/openstack-meta-2020.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-cluster/openstack-meta/openstack-meta-2020.2.0.ebuild b/sys-cluster/openstack-meta/openstack-meta-2020.2.0.ebuild
new file mode 100644
index 000000000000..35f8d50288ec
--- /dev/null
+++ b/sys-cluster/openstack-meta/openstack-meta-2020.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A openstack meta-package for installing the various openstack pieces"
+HOMEPAGE="https://openstack.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="cinder glance heat keystone neutron nova placement swift"
+
+if [[ ${PV} != *9999 ]];then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND=""
+RDEPEND="
+ keystone? ( >=sys-auth/keystone-18.0.0
+ <sys-auth/keystone-19 )
+ swift? ( >=sys-cluster/swift-2.26.0
+ <sys-cluster/swift-2.27.0 )
+ neutron? ( >=sys-cluster/neutron-17.0.0
+ <sys-cluster/neutron-18 )
+ glance? ( >=app-admin/glance-21.0.0
+ <app-admin/glance-22 )
+ cinder? ( >=sys-cluster/cinder-17.0.0
+ <sys-cluster/cinder-18 )
+ nova? ( >=sys-cluster/nova-22.0.0
+ <sys-cluster/nova-23 )
+ heat? ( >=sys-cluster/heat-15.0.0
+ <sys-cluster/heat-16 )
+ placement? ( >=sys-cluster/placement-4.0.0
+ <sys-cluster/placement-5 )
+"