summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2018-01-25 09:31:18 +0100
committerUltrabug <ultrabug@gentoo.org>2018-01-25 09:31:18 +0100
commitb1871e509fba489c2e72d2697ff51926df1b5a2d (patch)
treece4bd8e5c09890d464c83d34c08c8127c006d8cd /sys-cluster/pacemaker/files
parentprofiles/package.mask: mask ruby22-only packages (diff)
downloadgentoo-b1871e509fba489c2e72d2697ff51926df1b5a2d.tar.gz
gentoo-b1871e509fba489c2e72d2697ff51926df1b5a2d.tar.bz2
gentoo-b1871e509fba489c2e72d2697ff51926df1b5a2d.zip
sys-cluster/pacemaker: drop vulnerable wrt #599194
Diffstat (limited to 'sys-cluster/pacemaker/files')
-rw-r--r--sys-cluster/pacemaker/files/pacemaker-1.1.10-tinfo.patch21
-rw-r--r--sys-cluster/pacemaker/files/pacemaker-1.1.12-glib.patch47
-rw-r--r--sys-cluster/pacemaker/files/pacemaker-1.1.12-stonith.patch21
3 files changed, 0 insertions, 89 deletions
diff --git a/sys-cluster/pacemaker/files/pacemaker-1.1.10-tinfo.patch b/sys-cluster/pacemaker/files/pacemaker-1.1.10-tinfo.patch
deleted file mode 100644
index 1dba440c9e79..000000000000
--- a/sys-cluster/pacemaker/files/pacemaker-1.1.10-tinfo.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/configure.ac 2014-12-12 14:13:07.262413254 +0100
-+++ b/configure.ac 2014-12-12 14:13:14.922480835 +0100
-@@ -885,14 +885,16 @@
- CURSESLIBS=''
- if test "$ac_cv_header_ncurses_h" = "yes"; then
- AC_CHECK_LIB(ncurses, printw,
-- [CURSESLIBS='-lncurses'; AC_DEFINE(HAVE_LIBNCURSES,1, have ncurses library)]
-+ [AC_DEFINE(HAVE_LIBNCURSES,1, have ncurses library)]
- )
-+ CURSESLIBS=`$PKGCONFIG --libs ncurses`;
- fi
-
- if test "$ac_cv_header_ncurses_ncurses_h" = "yes"; then
- AC_CHECK_LIB(ncurses, printw,
-- [CURSESLIBS='-lncurses'; AC_DEFINE(HAVE_LIBNCURSES,1, have ncurses library)]
-+ [AC_DEFINE(HAVE_LIBNCURSES,1, have ncurses library)]
- )
-+ CURSESLIBS=`$PKGCONFIG --libs ncurses`;
- fi
-
- dnl Only look for non-n-library if there was no n-library.
diff --git a/sys-cluster/pacemaker/files/pacemaker-1.1.12-glib.patch b/sys-cluster/pacemaker/files/pacemaker-1.1.12-glib.patch
deleted file mode 100644
index 8233f98a17e8..000000000000
--- a/sys-cluster/pacemaker/files/pacemaker-1.1.12-glib.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 568e41db929a34106c8c2ff7c48716ab5c13ef49 Mon Sep 17 00:00:00 2001
-From: Andrew Beekhof <andrew@beekhof.net>
-Date: Mon, 13 Oct 2014 13:30:58 +1100
-Subject: [PATCH] Fix: lrmd: Prevent glib assert triggered by timers being
- removed from mainloop more than once
-
----
- lib/services/services.c | 3 +++
- lib/services/services_linux.c | 1 +
- 2 files changed, 4 insertions(+)
-
---- a/lib/services/services.c
-+++ b/lib/services/services.c
-@@ -313,6 +313,7 @@ services_action_free(svc_action_t * op)
-
- if (op->opaque->repeat_timer) {
- g_source_remove(op->opaque->repeat_timer);
-+ op->opaque->repeat_timer = 0;
- }
- if (op->opaque->stderr_gsource) {
- mainloop_del_fd(op->opaque->stderr_gsource);
-@@ -425,6 +426,7 @@ services_action_kick(const char *name, c
- } else {
- if (op->opaque->repeat_timer) {
- g_source_remove(op->opaque->repeat_timer);
-+ op->opaque->repeat_timer = 0;
- }
- recurring_action_timer(op);
- return TRUE;
-@@ -459,6 +461,7 @@ handle_duplicate_recurring(svc_action_t
- if (dup->pid != 0) {
- if (op->opaque->repeat_timer) {
- g_source_remove(op->opaque->repeat_timer);
-+ op->opaque->repeat_timer = 0;
- }
- recurring_action_timer(dup);
- }
---- a/lib/services/services_linux.c
-+++ b/lib/services/services_linux.c
-@@ -226,6 +226,7 @@ recurring_action_timer(gpointer data)
- op->stdout_data = NULL;
- free(op->stderr_data);
- op->stderr_data = NULL;
-+ op->opaque->repeat_timer = 0;
-
- services_action_async(op, NULL);
- return FALSE;
diff --git a/sys-cluster/pacemaker/files/pacemaker-1.1.12-stonith.patch b/sys-cluster/pacemaker/files/pacemaker-1.1.12-stonith.patch
deleted file mode 100644
index 31c729559f35..000000000000
--- a/sys-cluster/pacemaker/files/pacemaker-1.1.12-stonith.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Description: Fix: stonith-ng: Reset mainloop source IDs after removing them
-
-Origin: upstream, commit: 0326f05c9e26f39a394fa30830e31a76306f49c7
-Author: Andrew Beekhof <andrew@beekhof.net>
-Bug-Ubuntu: https://bugs.launchpad.net/bugs/1412962
-Last-Update: 2015-01-20
-
---- a/lib/fencing/st_client.c
-+++ b/lib/fencing/st_client.c
-@@ -663,9 +663,11 @@ stonith_action_async_done(mainloop_child
-
- if (action->timer_sigterm > 0) {
- g_source_remove(action->timer_sigterm);
-+ action->timer_sigterm = 0;
- }
- if (action->timer_sigkill > 0) {
- g_source_remove(action->timer_sigkill);
-+ action->timer_sigkill = 0;
- }
-
- if (action->last_timeout_signo) {