summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /sys-cluster/pacemaker/pacemaker-1.1.19-r1.ebuild
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-cluster/pacemaker/pacemaker-1.1.19-r1.ebuild')
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.19-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.19-r1.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.19-r1.ebuild
index ed65ac8337a0..879fa861bc17 100644
--- a/sys-cluster/pacemaker/pacemaker-1.1.19-r1.ebuild
+++ b/sys-cluster/pacemaker/pacemaker-1.1.19-r1.ebuild
@@ -71,10 +71,10 @@ src_configure() {
src_install() {
default
rm -rf "${D}/var/run" "${D}/etc/init.d"
- newinitd "${FILESDIR}/${PN}.initd" "${PN}" || die
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
if has_version "<sys-cluster/corosync-2.0"; then
insinto /etc/corosync/service.d
- newins "${FILESDIR}/${PN}.service" "${PN}" || die
+ newins "${FILESDIR}/${PN}.service" "${PN}"
fi
find "${D}" -name '*.la' -delete || die
}