summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-18 17:12:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-18 17:12:29 -0500
commit2454315559d710cd673f0a3bfe42cb314397ae31 (patch)
tree7f543bdc4e5f85298fdf9bfe3ea5488594221e09 /sys-cluster/placement
parentdev-python/microversion-parse: 1.0.1 bump (diff)
downloadgentoo-2454315559d710cd673f0a3bfe42cb314397ae31.tar.gz
gentoo-2454315559d710cd673f0a3bfe42cb314397ae31.tar.bz2
gentoo-2454315559d710cd673f0a3bfe42cb314397ae31.zip
sys-cluster/placement: VICTORIA
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-cluster/placement')
-rw-r--r--sys-cluster/placement/Manifest3
-rw-r--r--sys-cluster/placement/placement-2020.2.9999.ebuild77
-rw-r--r--sys-cluster/placement/placement-4.0.0.ebuild77
3 files changed, 157 insertions, 0 deletions
diff --git a/sys-cluster/placement/Manifest b/sys-cluster/placement/Manifest
index 1f24e0e73c83..3fbd7292dfde 100644
--- a/sys-cluster/placement/Manifest
+++ b/sys-cluster/placement/Manifest
@@ -1,3 +1,6 @@
DIST openstack-placement-3.0.0.tar.gz 502408 BLAKE2B daf5d3b441a10fc9d1be03df52e9df265cecc61d74fd1c5eff0b6acc36011fb3defb8d4233e597b4b1445fb56a77d746343f9021e5b0073272d7e30e830571b3 SHA512 b3735d8b74019c71c5eef9d5a4331c9370c1224d8caeaeb5fdbc81577778dc9795b729df00abc3e06175dc5c7f401daacbbd331aa9295e84cb76abd013d7aa2a
+DIST openstack-placement-4.0.0.tar.gz 502434 BLAKE2B 9c769d2ef78bad37ef6ac823c9b0fa29128bfea94626f6a4e9cd1ffa6e1e4d441e4b20353e97282823bc1638ee25499fa840b9d34600b1928271627d412c93cc SHA512 32ff30f7216ea56b073582c2e1c4b501229d941f3c6fc501245ab92544234774df63a9b9674ba5f1225d462ab205b2512185907e309e4135e01e1776d554b293
DIST placement.conf.sample-2020.1.9999 26302 BLAKE2B 077c85c86b7b2fa83b8ac7f41a2fdf5e64bcc8c82f9252e2bb0c7be164944a9c11cb14eb3911f37945e5de8faa7e7a5e2de4df656ed80a0f208105a8c6db7cb0 SHA512 179913a1908bc688220d10d908d487fdf59bab56213051569fe4f8ac233242c9f9eca3ba4293a2f049c46e68eeca62aa7bc0ba0f61d9276247b166abb063eb3a
+DIST placement.conf.sample-2020.2.9999 26306 BLAKE2B 037ce73d52066fc2f2fe0542c10e3879c513ca23f127a03cd575cca0d21f7b2f4f36491c238897cacd962072797d9d2fd50be054c3ae09f95f5417ab9758b289 SHA512 640329729d0964b67a25837692f0db0f5e9682aff6bd1f3e124657c4bc0de7f6a9f65a5c17889cd6c0a0584d471c880865a59b939262ed8beac2ae452d0ea02a
DIST placement.conf.sample-3.0.0 26302 BLAKE2B 077c85c86b7b2fa83b8ac7f41a2fdf5e64bcc8c82f9252e2bb0c7be164944a9c11cb14eb3911f37945e5de8faa7e7a5e2de4df656ed80a0f208105a8c6db7cb0 SHA512 179913a1908bc688220d10d908d487fdf59bab56213051569fe4f8ac233242c9f9eca3ba4293a2f049c46e68eeca62aa7bc0ba0f61d9276247b166abb063eb3a
+DIST placement.conf.sample-4.0.0 26306 BLAKE2B 037ce73d52066fc2f2fe0542c10e3879c513ca23f127a03cd575cca0d21f7b2f4f36491c238897cacd962072797d9d2fd50be054c3ae09f95f5417ab9758b289 SHA512 640329729d0964b67a25837692f0db0f5e9682aff6bd1f3e124657c4bc0de7f6a9f65a5c17889cd6c0a0584d471c880865a59b939262ed8beac2ae452d0ea02a
diff --git a/sys-cluster/placement/placement-2020.2.9999.ebuild b/sys-cluster/placement/placement-2020.2.9999.ebuild
new file mode 100644
index 000000000000..e54645cb04c1
--- /dev/null
+++ b/sys-cluster/placement/placement-2020.2.9999.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="A HTTP service for managing, selecting, and claiming cloud resources."
+HOMEPAGE="https://github.com/openstack/placement"
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/placement/victoria/placement.conf.sample -> placement.conf.sample-${PV}"
+ EGIT_REPO_URI="https://github.com/openstack/placement.git"
+ EGIT_BRANCH="stable/victoria"
+else
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/placement/victoria/placement.conf.sample -> placement.conf.sample-${PV}
+ https://tarballs.openstack.org/${PN}/openstack-${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/openstack-${P}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="mysql postgres sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=">=dev-python/pbr-5.0.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-5.0.0[${PYTHON_USEDEP}]
+ sqlite? (
+ >=dev-python/sqlalchemy-1.2.19[${PYTHON_USEDEP}]
+ )
+ mysql? (
+ >=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}]
+ !~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.2.19[${PYTHON_USEDEP}]
+ )
+ postgres? (
+ >=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.2.19[${PYTHON_USEDEP}]
+ )
+ >=dev-python/keystonemiddleware-4.18.0[${PYTHON_USEDEP}]
+ >=dev-python/routes-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.8.2[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-6.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.37.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-db-4.40.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-middleware-3.31.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-upgradecheck-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/os-resource-classes-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/os-traits-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/microversion-parse-0.2.1[${PYTHON_USEDEP}]
+ acct-user/placement
+ acct-group/placement"
+BDEPEND=""
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ diropts -m 0750 -o placement -g placement
+ insinto /etc/placement
+ insopts -m 0640 -o placement -g placement
+ newins "${DISTDIR}/placement.conf.sample-${PV}" placement.conf.sample
+
+ dobin tools/mysql-migrate-db.sh
+ dobin tools/postgresql-migrate-db.sh
+}
diff --git a/sys-cluster/placement/placement-4.0.0.ebuild b/sys-cluster/placement/placement-4.0.0.ebuild
new file mode 100644
index 000000000000..e54645cb04c1
--- /dev/null
+++ b/sys-cluster/placement/placement-4.0.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="A HTTP service for managing, selecting, and claiming cloud resources."
+HOMEPAGE="https://github.com/openstack/placement"
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/placement/victoria/placement.conf.sample -> placement.conf.sample-${PV}"
+ EGIT_REPO_URI="https://github.com/openstack/placement.git"
+ EGIT_BRANCH="stable/victoria"
+else
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/placement/victoria/placement.conf.sample -> placement.conf.sample-${PV}
+ https://tarballs.openstack.org/${PN}/openstack-${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/openstack-${P}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="mysql postgres sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=">=dev-python/pbr-5.0.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-5.0.0[${PYTHON_USEDEP}]
+ sqlite? (
+ >=dev-python/sqlalchemy-1.2.19[${PYTHON_USEDEP}]
+ )
+ mysql? (
+ >=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}]
+ !~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.2.19[${PYTHON_USEDEP}]
+ )
+ postgres? (
+ >=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.2.19[${PYTHON_USEDEP}]
+ )
+ >=dev-python/keystonemiddleware-4.18.0[${PYTHON_USEDEP}]
+ >=dev-python/routes-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.8.2[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-6.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.37.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-db-4.40.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-middleware-3.31.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-upgradecheck-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/os-resource-classes-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/os-traits-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/microversion-parse-0.2.1[${PYTHON_USEDEP}]
+ acct-user/placement
+ acct-group/placement"
+BDEPEND=""
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ diropts -m 0750 -o placement -g placement
+ insinto /etc/placement
+ insopts -m 0640 -o placement -g placement
+ newins "${DISTDIR}/placement.conf.sample-${PV}" placement.conf.sample
+
+ dobin tools/mysql-migrate-db.sh
+ dobin tools/postgresql-migrate-db.sh
+}