summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-09-05 21:37:00 +0200
committerMarek Szuba <marecki@gentoo.org>2020-09-05 21:43:46 +0200
commit8895632584d0d291b170c0efea0599b707163b63 (patch)
treea54020b9b855721bc1a5dddc520ccea43c4325ed /sys-cluster/singularity
parentmedia-libs/gmmlib: remove old (diff)
downloadgentoo-8895632584d0d291b170c0efea0599b707163b63.tar.gz
gentoo-8895632584d0d291b170c0efea0599b707163b63.tar.bz2
gentoo-8895632584d0d291b170c0efea0599b707163b63.zip
sys-cluster/singularity: remove old
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest2
-rw-r--r--sys-cluster/singularity/singularity-3.6.0.ebuild69
-rw-r--r--sys-cluster/singularity/singularity-3.6.1.ebuild73
3 files changed, 0 insertions, 144 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index 8bd83c7f905b..f7800e563b4b 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,3 +1 @@
-DIST singularity-3.6.0.tar.gz 6169388 BLAKE2B ea07da3d586a96625a1016f9b4aa6b99072c89393dcb7c80aab624807e51fc107eee2629020bf3e1c19d6103544b63aad960d2ac27804fa6e03323a806fdf270 SHA512 695f3b4c1bd8cc4049fc3e8e296b369f5aadcd6b4717521b9aca68d997fd8a8c0bf349a2851c31b8a22f37fa010b4c7b93562fd6ac24cdc9699230a182f36d29
-DIST singularity-3.6.1.tar.gz 6170806 BLAKE2B fa92bf4df3c2a4ab4345ab0022862f19dde240d7275a79c8433164f02bc495f33d44e4c63b39b9bd3de60361e49fec3f2d258a3bafaadeba34b5d4a7cd3f514e SHA512 3037a14fec086e17b42ee8306624af39fd87c80821c73e0e1ab3d8a717dbdad86237f042d97c6a7870fc6beeced67d6cd52c8e445c41c39cdab7ccce1ce6adb5
DIST singularity-3.6.2.tar.gz 5933938 BLAKE2B 86b79687ef7591a255d01b83e857d87b7ab45aa9a84c40a7c90b493c0fc04cb33ff4f1616f38c5178e22ff1b19d390ab3b96f0fb05d6c66534e60d9ef2d7ea33 SHA512 fed2ebd286a3f250d8f4a7677e4bc0b13ec9b2e2eacff91c9a7f6efe6abc766a2d1b713bc291f0239585d5dacd5d4657309ef81eceb77f849f01be934a76499f
diff --git a/sys-cluster/singularity/singularity-3.6.0.ebuild b/sys-cluster/singularity/singularity-3.6.0.ebuild
deleted file mode 100644
index 202258ead7a6..000000000000
--- a/sys-cluster/singularity/singularity-3.6.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info
-
-DESCRIPTION="Application containers for Linux"
-HOMEPAGE="https://sylabs.io"
-SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples +network +suid"
-
-# Do not complain about CFLAGS etc since go projects do not use them.
-QA_FLAGS_IGNORED='.*'
-
-COMMON="sys-libs/libseccomp"
-BDEPEND="virtual/pkgconfig"
-DEPEND="${COMMON}
- >=dev-lang/go-1.13.0
- app-crypt/gpgme
- dev-libs/openssl
- sys-apps/util-linux
- sys-fs/cryptsetup"
-RDEPEND="${COMMON}
- sys-fs/squashfs-tools"
-
-CONFIG_CHECK="~SQUASHFS"
-
-S=${WORKDIR}/${PN}
-
-src_configure() {
- local myconfargs=(
- --prefix=/usr \
- --sysconfdir=/etc \
- --runstatedir=/run \
- --localstatedir=/var \
- $(usex network "" "--without-network") \
- $(usex suid "" "--without-suid")
- )
- ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
-}
-
-src_compile() {
- emake -C builddir
-}
-
-src_install() {
- emake DESTDIR="${ED}" -C builddir install
- keepdir /var/singularity/mnt/session
-
- # As of version 3.5.3 this seems to be very much broken, affecting
- # commands which have got nothing to do with singularity (example:
- # completion on 'udisks mount -b /dev/' rejects all files from that
- # directory other than 'autofs'). Moreover, this should go into
- # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
- # Hopefully temporary, which is why we delete this at install time
- # instead of patching build scripts not to generate bash-completion
- # data in the first place.
- rm -rf "${ED}"/etc/bash_completion.d || die
-
- dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
- if use examples; then
- dodoc -r examples
- fi
-}
diff --git a/sys-cluster/singularity/singularity-3.6.1.ebuild b/sys-cluster/singularity/singularity-3.6.1.ebuild
deleted file mode 100644
index 23232305c173..000000000000
--- a/sys-cluster/singularity/singularity-3.6.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info toolchain-funcs
-
-DESCRIPTION="Application containers for Linux"
-HOMEPAGE="https://sylabs.io"
-SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples +network +suid"
-
-# Do not complain about CFLAGS etc since go projects do not use them.
-QA_FLAGS_IGNORED='.*'
-
-COMMON="sys-libs/libseccomp"
-BDEPEND="virtual/pkgconfig"
-DEPEND="${COMMON}
- >=dev-lang/go-1.13.0
- app-crypt/gpgme
- dev-libs/openssl
- sys-apps/util-linux
- sys-fs/cryptsetup"
-RDEPEND="${COMMON}
- sys-fs/squashfs-tools"
-
-CONFIG_CHECK="~SQUASHFS"
-
-S=${WORKDIR}/${PN}
-
-src_configure() {
- local myconfargs=(
- -c "$(tc-getBUILD_CC)" \
- -x "$(tc-getBUILD_CXX)" \
- -C "$(tc-getCC)" \
- -X "$(tc-getCXX)" \
- --prefix=/usr \
- --sysconfdir=/etc \
- --runstatedir=/run \
- --localstatedir=/var \
- $(usex network "" "--without-network") \
- $(usex suid "" "--without-suid")
- )
- ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
-}
-
-src_compile() {
- emake -C builddir
-}
-
-src_install() {
- emake DESTDIR="${ED}" -C builddir install
- keepdir /var/singularity/mnt/session
-
- # As of version 3.5.3 this seems to be very much broken, affecting
- # commands which have got nothing to do with singularity (example:
- # completion on 'udisks mount -b /dev/' rejects all files from that
- # directory other than 'autofs'). Moreover, this should go into
- # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
- # Hopefully temporary, which is why we delete this at install time
- # instead of patching build scripts not to generate bash-completion
- # data in the first place.
- rm -rf "${ED}"/etc/bash_completion.d || die
-
- dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
- if use examples; then
- dodoc -r examples
- fi
-}