summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2019-07-07 07:46:28 +0100
committerJustin Lecher <jlec@gentoo.org>2019-07-07 07:49:07 +0100
commitda00598904de34d68c2b62fdb343246cda5a4be5 (patch)
tree9b7e9fc2438ea182628acc76cfd43cadd7b36c99 /sys-cluster/ucx/ucx-1.5.2.ebuild
parentsys-fs/aufs-util: Version Bump (diff)
downloadgentoo-da00598904de34d68c2b62fdb343246cda5a4be5.tar.gz
gentoo-da00598904de34d68c2b62fdb343246cda5a4be5.tar.bz2
gentoo-da00598904de34d68c2b62fdb343246cda5a4be5.zip
sys-cluster/ucx: Version Bump
Package-Manager: Portage-2.3.68, Repoman-2.3.12 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-cluster/ucx/ucx-1.5.2.ebuild')
-rw-r--r--sys-cluster/ucx/ucx-1.5.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-cluster/ucx/ucx-1.5.2.ebuild b/sys-cluster/ucx/ucx-1.5.2.ebuild
new file mode 100644
index 000000000000..55ec075ba427
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="http://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ numa? ( sys-process/numactl )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}
+
+src_compile() {
+ BASE_CFLAGS="" emake
+}