summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-23 21:36:31 +0100
committerSam James <sam@gentoo.org>2021-09-23 21:36:49 +0100
commit146fff709a4168bd9011831dfb64ff3a021855e9 (patch)
tree16a093172a3819a234d414d6db1ff7db32b49520 /sys-cluster
parentmedia-sound/pulseaudio: move manpage build deps to BDEPEND (diff)
downloadgentoo-146fff709a4168bd9011831dfb64ff3a021855e9.tar.gz
gentoo-146fff709a4168bd9011831dfb64ff3a021855e9.tar.bz2
gentoo-146fff709a4168bd9011831dfb64ff3a021855e9.zip
sys-cluster/mpich: workaround build failure with GCC 10 (stable)
Bug: https://bugs.gentoo.org/725842 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich/mpich-3.0.4.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sys-cluster/mpich/mpich-3.0.4.ebuild b/sys-cluster/mpich/mpich-3.0.4.ebuild
index 15abf189bc81..828fec76358a 100644
--- a/sys-cluster/mpich/mpich-3.0.4.ebuild
+++ b/sys-cluster/mpich/mpich-3.0.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
FORTRAN_NEEDED=fortran
-inherit fortran-2
+inherit fortran-2 flag-o-matic
MY_PV=${PV/_/}
DESCRIPTION="A high performance and portable MPI implementation"
@@ -72,15 +72,21 @@ src_configure() {
c="${c} --sysconfdir=${EPREFIX}/etc/${PN}"
c="${c} --docdir=${EPREFIX}/usr/share/doc/${PF}"
+ # GCC 10 compatibility workaround
+ # bug #725842
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
export MPICHLIB_CFLAGS=${CFLAGS}
export MPICHLIB_CPPFLAGS=${CPPFLAGS}
export MPICHLIB_CXXFLAGS=${CXXFLAGS}
export MPICHLIB_FFLAGS=${FFLAGS}
export MPICHLIB_FCFLAGS=${FCFLAGS}
export MPICHLIB_LDFLAGS=${LDFLAGS}
- unset CFLAGS CPPFLAGS CXXFLAGS FFLAGS FCFLAGS LDFLAGS
+ # dropped w/ bug #725842 fix
+ #unset CFLAGS CPPFLAGS CXXFLAGS FFLAGS FCFLAGS LDFLAGS
- econf ${c} \
+ # Forcing Bash as there's quite a few bashisms in the build system
+ CONFIG_SHELL="${BROOT}/bin/bash" econf \
--with-pm=hydra \
--disable-mpe \
--disable-fast \