summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-05 18:34:11 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-05 18:34:30 +0200
commit1fefcbb0703cd634dd459e84fe1c95949edd113b (patch)
tree7f1beb3e345f4e69ae9e05baec5d6b50cced99e9 /sys-cluster
parentnet-analyzer/prometheus: Remove old (diff)
downloadgentoo-1fefcbb0703cd634dd459e84fe1c95949edd113b.tar.gz
gentoo-1fefcbb0703cd634dd459e84fe1c95949edd113b.tar.bz2
gentoo-1fefcbb0703cd634dd459e84fe1c95949edd113b.zip
sys-cluster/kubectl: Misc fixes
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/kubectl/kubectl-1.6.4.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-cluster/kubectl/kubectl-1.6.4.ebuild b/sys-cluster/kubectl/kubectl-1.6.4.ebuild
index 637d85f31c80..4866ab70285e 100644
--- a/sys-cluster/kubectl/kubectl-1.6.4.ebuild
+++ b/sys-cluster/kubectl/kubectl-1.6.4.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit user golang-build golang-vcs-snapshot
+inherit golang-build golang-vcs-snapshot
-EGO_PN="k8s.io/kubernetes/..."
+EGO_PN="k8s.io/kubernetes"
ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
KEYWORDS="~amd64"
@@ -22,16 +22,16 @@ RESTRICT="test"
src_prepare() {
default
- sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" src/${EGO_PN%/*}/hack/lib/golang.sh || die
- sed -i -e "/export PATH/d" src/${EGO_PN%/*}/hack/generate-bindata.sh || die
+ sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" src/${EGO_PN}/hack/lib/golang.sh || die
+ sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
}
src_compile() {
- LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN%/*} WHAT=cmd/${PN}
+ LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN}
}
src_install() {
- pushd src/${EGO_PN%/*} || die
+ pushd src/${EGO_PN} || die
dobin _output/bin/${PN}
popd || die
}