summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-11-10 16:28:39 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-11-10 16:54:09 -0600
commit238a9427208e5ffa4b23f8c6832979bd208d4579 (patch)
tree3314a71bff9be470741df75ad0322691774fc14b /sys-cluster
parentprofiles/package.mask: temporary mask for new mercurial (diff)
downloadgentoo-238a9427208e5ffa4b23f8c6832979bd208d4579.tar.gz
gentoo-238a9427208e5ffa4b23f8c6832979bd208d4579.tar.bz2
gentoo-238a9427208e5ffa4b23f8c6832979bd208d4579.zip
sys-cluster/swift: 2.25.1 stable amd64 / x86 with cleanup
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/swift/Manifest1
-rw-r--r--sys-cluster/swift/swift-2.25.0.ebuild113
-rw-r--r--sys-cluster/swift/swift-2.25.1.ebuild2
3 files changed, 1 insertions, 115 deletions
diff --git a/sys-cluster/swift/Manifest b/sys-cluster/swift/Manifest
index dd6cda07eb33..627cf1e56521 100644
--- a/sys-cluster/swift/Manifest
+++ b/sys-cluster/swift/Manifest
@@ -1,3 +1,2 @@
-DIST swift-2.25.0.tar.gz 3183764 BLAKE2B 865cfcc832edb1f30a4529b0ff550c987a7413c841b9f1ef0d0a145f5be55762963b32ea332aa6f51690a871124e84dc7fb036309f38d4120a1e095e60bfaa34 SHA512 60cbc4bae61bb287e93d9a6a4e9a58a9c97f407d07927dde99c923d1ee7ab4ef79350c7c0cdcaab8aa0944aee09c27da549f3ebf86eb9bb92766b2b301d593a2
DIST swift-2.25.1.tar.gz 3161690 BLAKE2B 985bcb884f4de9a7a4fbb8e2e76ff416035ac4554d3135c04d679c1d88a8443b988b5a18b4f3f1864542c93109020bb77eef72836fd40e705a9293c8a481e4f0 SHA512 4943949a420fa174e30c178b07797af4dceb89174c2e13ac9db35ff66a648024c907b52b9cdba2f730bc587b4d712efa3da09e77ccca51bd537703fc3c17144b
DIST swift-2.26.0.tar.gz 3235050 BLAKE2B 33b46ebc3bd57b6ca6ccb65e96dd11a754fa1b4d314c60eafd23ad8b6bb7b8fee42ce26ccf0f388ad33599520a049a2d36832ba3d1ea01b0a07a8bee3f803569 SHA512 5e4620831bfc75f231fa468ce68438a23ad7b013eef4173aa596fd2e42bd4eb7e6b4182026fa71b6f4dd31d2cfccc4e70480a42a77f93b15bf6e50e9287ea460
diff --git a/sys-cluster/swift/swift-2.25.0.ebuild b/sys-cluster/swift/swift-2.25.0.ebuild
deleted file mode 100644
index aa8c6a1c6e5b..000000000000
--- a/sys-cluster/swift/swift-2.25.0.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit distutils-r1 eutils linux-info
-
-DESCRIPTION="A highly available, distributed, and eventually consistent object/blob store"
-HOMEPAGE="https://launchpad.net/swift"
-if [[ ${PV} == *9999 ]];then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/openstack/swift.git"
- EGIT_BRANCH="stable/ussuri"
-else
- SRC_URI="https://tarballs.openstack.org/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 x86"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="account container doc +memcached +object proxy"
-REQUIRED_USE="|| ( proxy account container object )"
-
-CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
-
-RDEPEND="
- ${CDEPEND}
- >=dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.8[${PYTHON_USEDEP}]
- !~dev-python/netifaces-0.10.0[${PYTHON_USEDEP}]
- !~dev-python/netifaces-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- dev-python/pyxattr[${PYTHON_USEDEP}]
- >=dev-python/PyECLib-1.3.1[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.0.2[${PYTHON_USEDEP}]
- memcached? ( net-misc/memcached )
- net-misc/rsync[xattr]
- acct-user/swift
- acct-group/swift"
-
-pkg_pretend() {
- linux-info_pkg_setup
- CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
- ~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
- ~ZFS"
- if linux_config_exists; then
- for module in ${CONFIG_CHECK}; do
- linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled"
- done
- fi
-}
-
-src_prepare() {
- sed -i 's/xattr/pyxattr/g' requirements.txt || die
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- keepdir /etc/swift
- insinto /etc/swift
-
- newins "etc/swift.conf-sample" "swift.conf"
- newins "etc/rsyncd.conf-sample" "rsyncd.conf"
- newins "etc/mime.types-sample" "mime.types-sample"
- newins "etc/memcache.conf-sample" "memcache.conf-sample"
- newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
- newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
-
- if use proxy; then
- newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
- newins "etc/proxy-server.conf-sample" "proxy-server.conf"
- if use memcached; then
- sed -i '/depend/a\ need memcached' "${D}/etc/init.d/swift-proxy"
- fi
- fi
- if use account; then
- newinitd "${FILESDIR}/swift-account.initd" "swift-account"
- newins "etc/account-server.conf-sample" "account-server.conf"
- fi
- if use container; then
- newinitd "${FILESDIR}/swift-container.initd" "swift-container"
- newins "etc/container-server.conf-sample" "container-server.conf"
- fi
- if use object; then
- newinitd "${FILESDIR}/swift-object.initd" "swift-object"
- newins "etc/object-server.conf-sample" "object-server.conf"
- newins "etc/object-expirer.conf-sample" "object-expirer.conf"
- fi
-
- if use doc; then
- doman doc/manpages/*
- dodoc -r doc/{s3api,saio,source}
- fi
-
- fowners root:swift "/etc/swift"
- fperms 0750 /etc/swift
-}
-
-pkg_postinst() {
- elog "Openstack swift will default to using insecure http unless a"
- elog "certificate is created in /etc/swift/cert.crt and the associated key"
- elog "in /etc/swift/cert.key. These can be created with the following:"
- elog " * cd /etc/swift"
- elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
-}
diff --git a/sys-cluster/swift/swift-2.25.1.ebuild b/sys-cluster/swift/swift-2.25.1.ebuild
index 8ac84d6415d8..aa8c6a1c6e5b 100644
--- a/sys-cluster/swift/swift-2.25.1.ebuild
+++ b/sys-cluster/swift/swift-2.25.1.ebuild
@@ -14,7 +14,7 @@ if [[ ${PV} == *9999 ]];then
EGIT_BRANCH="stable/ussuri"
else
SRC_URI="https://tarballs.openstack.org/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
+ KEYWORDS="amd64 ~arm64 x86"
fi
LICENSE="Apache-2.0"