summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-01-15 17:16:44 -0700
committerChristoph Junghans <junghans@gentoo.org>2017-01-15 17:17:01 -0700
commit23ab613d3391c7124b9d83c65dfa6bb842535c93 (patch)
treeb2b793794cad2833ce71d7dfe434d186a1ad0ce4 /sys-cluster
parentsys-cluster/libquo: update homepage (diff)
downloadgentoo-23ab613d3391c7124b9d83c65dfa6bb842535c93.tar.gz
gentoo-23ab613d3391c7124b9d83c65dfa6bb842535c93.tar.bz2
gentoo-23ab613d3391c7124b9d83c65dfa6bb842535c93.zip
sys-cluster/libquo: import live ebuild for sci overlay
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/libquo/libquo-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-cluster/libquo/libquo-9999.ebuild b/sys-cluster/libquo/libquo-9999.ebuild
new file mode 100644
index 000000000000..68615e034b10
--- /dev/null
+++ b/sys-cluster/libquo/libquo-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD=90
+
+inherit fortran-2
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/lanl/${PN}.git https://github.com/lanl/${PN}.git"
+ inherit autotools git-r3
+ KEYWORDS=""
+else
+ SRC_URI="http://lanl.github.io/${PN}/dists/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="run-time tuning of process binding policies made easy"
+HOMEPAGE="http://lanl.github.io/libquo/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="fortran static-libs test"
+
+DEPEND="
+ virtual/mpi[fortran?]
+ sys-process/numactl
+ sys-apps/hwloc[numa,xml]
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf CC=mpicc FC=$(usex fortran mpif90 false)
+}