summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2020-08-12 15:06:14 +0000
committerSam James <sam@gentoo.org>2020-08-12 15:06:14 +0000
commit245ac0ef00c215baea76f892e04454434f87cbfc (patch)
tree842f3e977935d31b693f61eff381f77989222254 /sys-cluster
parentnet-misc/glusterfs: maintainership via proxy-maint for myself. (diff)
downloadgentoo-245ac0ef00c215baea76f892e04454434f87cbfc.tar.gz
gentoo-245ac0ef00c215baea76f892e04454434f87cbfc.tar.bz2
gentoo-245ac0ef00c215baea76f892e04454434f87cbfc.zip
sys-cluster/glusterfs: version bump 7.7
Include fix for flock. Drop seek fix that's included upstream. Bug: https://bugs.gentoo.org/733228 Additional references: https://bugzilla.redhat.com/show_bug.cgi?id=1718562 https://bugzilla.redhat.com/show_bug.cgi?id=1776152 https://review.gluster.org/#/c/glusterfs/+/23794/8/xlators/features/locks/src/common.c Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/16790 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/glusterfs/Manifest1
-rw-r--r--sys-cluster/glusterfs/files/glusterfs-7.7-flock.patch65
-rw-r--r--sys-cluster/glusterfs/glusterfs-7.7.ebuild211
3 files changed, 277 insertions, 0 deletions
diff --git a/sys-cluster/glusterfs/Manifest b/sys-cluster/glusterfs/Manifest
index f447cd32c5d2..83fad50ecf9d 100644
--- a/sys-cluster/glusterfs/Manifest
+++ b/sys-cluster/glusterfs/Manifest
@@ -2,3 +2,4 @@ DIST glusterfs-6.8.tar.gz 7572097 BLAKE2B 76b7c699a4fc864d8074b591b3583030d837a0
DIST glusterfs-6.9.tar.gz 7580928 BLAKE2B 655544b7ffa70ac9980e1a1041af538f473b6b6c8cb77f6e3447908b903b3a2b3ee0234c18fb71f997f31f24f8a790ab2f5a05a6b392090601db455ac726262a SHA512 3bf167aed4f572f94ad4708c5fff7b578a334af1eb0322c36e15127a2089b6359e8d91a36793d8af93c8f76dbdf6ded649c3e0a6c1a879163c8d8b640cea334b
DIST glusterfs-7.5.tar.gz 7649044 BLAKE2B 01088654051a33c3a009b42c6e7adf7cabc52927a83a3331eced428ed3e6bfb3f7198fcc53a2b1dce678ac58c2f2619d02cce72a9850a50f3a26b37d39baeeaa SHA512 dfd8f04fb398daa7d7f58ef978ab69c0a55a313ac2af3287f7e1e7044f708317227c8749af5fd8d56844dfb8ad47bbd3214c42b806e2e21191a6a8617ab0be38
DIST glusterfs-7.6.tar.gz 7653500 BLAKE2B ff3d4817f2a8b85126669cfbe6f58990aaccfffd91464d7acd97d7092c8eb94c21552eaf5e2301e3e6a7f99534b40c2afce1ade593d8ac559baee2d175538333 SHA512 c26b2046e7afdbb37fdd395fd9f692a0513ebb58c91ea223fbbaf9f8b41641b1fd009f2975e187f0feb8d83fb5cd4a8a0c2fdf4591a8a31e920d6bba75ae7c0f
+DIST glusterfs-7.7.tar.gz 7675420 BLAKE2B cadd415053d791f5fe4fddbc45bf237275b29fb0340202eaf81bbd2e98c8e7a1b59fa276b8b47679224198675759287a2245095a751602a866d512155dfa73c8 SHA512 0a301802920e337a4931ed36133c76ef551e0c1794d324e5a0a120d289a53fb8a4a2fd8adaa7abe5a40b8b17cc2bb18d01426c9f18d91f68b1589429ddbaa125
diff --git a/sys-cluster/glusterfs/files/glusterfs-7.7-flock.patch b/sys-cluster/glusterfs/files/glusterfs-7.7-flock.patch
new file mode 100644
index 000000000000..f7930406cd18
--- /dev/null
+++ b/sys-cluster/glusterfs/files/glusterfs-7.7-flock.patch
@@ -0,0 +1,65 @@
+# https://bugs.gentoo.org/733228
+# https://bugzilla.redhat.com/show_bug.cgi?id=1718562
+# https://bugzilla.redhat.com/show_bug.cgi?id=1776152
+# https://review.gluster.org/#/c/glusterfs/+/23794/8/xlators/features/locks/src/common.c
+
+From 6ef82683064a87c434bd67e2004935281e4c04cc Mon Sep 17 00:00:00 2001
+From: l17zhou <cynthia.zhou@nokia-sbell.com>
+Date: Tue, 03 Dec 2019 07:43:35 +0200
+Subject: [PATCH] add clean local after grant lock
+
+found by flock test, without correct ref number of fd,
+lock will not be correctly released.
+
+Fixes: bz#1779089
+Change-Id: I3e466b17c852eb219c8778e43af8ad670a8449cc
+Signed-off-by: l17zhou <cynthia.zhou@nokia-sbell.com>
+---
+
+diff --git a/xlators/features/locks/src/common.c b/xlators/features/locks/src/common.c
+index c78d537..4c6b78c 100644
+--- a/xlators/features/locks/src/common.c
++++ b/xlators/features/locks/src/common.c
+@@ -962,7 +962,7 @@
+ struct list_head granted_list;
+ posix_lock_t *tmp = NULL;
+ posix_lock_t *lock = NULL;
+-
++ pl_local_t *local = NULL;
+ INIT_LIST_HEAD(&granted_list);
+
+ pthread_mutex_lock(&pl_inode->mutex);
+@@ -977,9 +977,9 @@
+
+ pl_trace_out(this, lock->frame, NULL, NULL, F_SETLKW, &lock->user_flock,
+ 0, 0, NULL);
+-
+- STACK_UNWIND_STRICT(lk, lock->frame, 0, 0, &lock->user_flock, NULL);
+-
++ local = lock->frame->local;
++ PL_STACK_UNWIND_AND_FREE(local, lk, lock->frame, 0, 0,
++ &lock->user_flock, NULL);
+ __destroy_lock(lock);
+ }
+
+@@ -999,6 +999,7 @@
+ struct list_head granted_list;
+ posix_lock_t *tmp = NULL;
+ posix_lock_t *lock = NULL;
++ pl_local_t *local = NULL;
+
+ int ret = -1;
+
+@@ -1026,9 +1027,9 @@
+
+ pl_trace_out(this, lock->frame, NULL, NULL, F_SETLKW, &lock->user_flock,
+ 0, 0, NULL);
+-
+- STACK_UNWIND_STRICT(lk, lock->frame, 0, 0, &lock->user_flock, NULL);
+-
++ local = lock->frame->local;
++ PL_STACK_UNWIND_AND_FREE(local, lk, lock->frame, 0, 0,
++ &lock->user_flock, NULL);
+ __destroy_lock(lock);
+ }
+
diff --git a/sys-cluster/glusterfs/glusterfs-7.7.ebuild b/sys-cluster/glusterfs/glusterfs-7.7.ebuild
new file mode 100644
index 000000000000..2f3011803d87
--- /dev/null
+++ b/sys-cluster/glusterfs/glusterfs-7.7.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit autotools elisp-common python-single-r1 systemd
+
+if [[ ${PV#9999} != ${PV} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gluster/glusterfs.git"
+else
+ SRC_URI="https://download.gluster.org/pub/gluster/${PN}/$(ver_cut 1)/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
+HOMEPAGE="https://www.gluster.org/"
+
+LICENSE="|| ( GPL-2 LGPL-3+ )"
+SLOT="0"
+IUSE="debug emacs +fuse +georeplication infiniband ipv6 libressl +libtirpc rsyslog static-libs +syslog test vim-syntax +xml"
+
+REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} )
+ ipv6? ( libtirpc )"
+
+# the tests must be run as root
+RESTRICT="test"
+
+# sys-apps/util-linux is required for libuuid
+RDEPEND="
+ acct-group/gluster
+ acct-user/gluster
+ dev-libs/libaio
+ dev-libs/userspace-rcu:=
+ net-libs/rpcsvc-proto
+ sys-apps/util-linux
+ sys-libs/readline:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+ fuse? ( >=sys-fs/fuse-2.7.0:0 )
+ georeplication? ( ${PYTHON_DEPS} )
+ infiniband? ( sys-fabric/libibverbs:* sys-fabric/librdmacm:* )
+ xml? ( dev-libs/libxml2 )
+ !elibc_glibc? ( sys-libs/argp-standalone )
+ libtirpc? ( net-libs/libtirpc:= )
+ !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
+ !libressl? ( dev-libs/openssl:=[-bindist] )
+ libressl? ( dev-libs/libressl:= )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/acl
+ test? ( >=dev-util/cmocka-1.0.1
+ app-benchmarks/dbench
+ dev-vcs/git
+ net-fs/nfs-utils
+ virtual/perl-Test-Harness
+ dev-libs/yajl
+ sys-fs/xfsprogs
+ sys-apps/attr )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-7.7-flock.patch"
+)
+
+# Maintainer notes:
+# * The build system will always configure & build argp-standalone but it'll never use it
+# if the argp.h header is found in the system. Which should be the case with
+# glibc or if argp-standalone is installed.
+
+pkg_setup() {
+ python_setup "python3*"
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # build rpc-transport and xlators only once as shared libs
+ find rpc/rpc-transport xlators -name Makefile.am |
+ xargs sed -i 's|.*$(top_srcdir).*\.sym|\0 -shared|' || die
+
+ # fix execution permissions
+ chmod +x libglusterfs/src/gen-defaults.py || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-fusermount \
+ $(use_enable debug) \
+ $(use_enable fuse fuse-client) \
+ $(use_enable georeplication) \
+ $(use_enable infiniband ibverbs) \
+ $(use_enable static-libs static) \
+ $(use_enable syslog) \
+ $(use_enable test cmocka) \
+ $(use_enable xml xml-output) \
+ $(use libtirpc || echo --without-libtirpc) \
+ $(use ipv6 && echo --with-ipv6-default) \
+ --with-tmpfilesdir="${EPREFIX}"/etc/tmpfiles.d \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ default
+ use emacs && elisp-compile extras/glusterfs-mode.el
+}
+
+src_install() {
+ default
+
+ rm \
+ "${ED}"/etc/glusterfs/glusterfs-{georep-,}logrotate \
+ "${ED}"/etc/glusterfs/gluster-rsyslog-*.conf \
+ "${ED}"/usr/share/doc/${PF}/glusterfs{-mode.el,.vim} || die "removing false files failed"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/glusterfs.logrotate glusterfs
+
+ if use rsyslog ; then
+ insinto /etc/rsyslog.d
+ newins extras/gluster-rsyslog-7.2.conf 60-gluster.conf
+ fi
+
+ if use emacs ; then
+ elisp-install ${PN} extras/glusterfs-mode.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
+ insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
+ fi
+
+ # insert some other tools which might be useful
+ insinto /usr/share/glusterfs/scripts
+ doins \
+ extras/backend-{cleanup,xattr-sanitize}.sh \
+ extras/clear_xattrs.sh \
+ extras/migrate-unify-to-distribute.sh
+
+ # correct permissions on installed scripts
+ # fperms 0755 /usr/share/glusterfs/scripts/*.sh
+ chmod 0755 "${ED}"/usr/share/glusterfs/scripts/*.sh || die
+
+ if use georeplication ; then
+ # move the gsync-sync-gfid tool to a binary path
+ # and set a symlink to be compliant with all other distros
+ mv "${ED}"/usr/{share/glusterfs/scripts/gsync-sync-gfid,libexec/glusterfs/} || die
+ dosym ../../../libexec/glusterfs/gsync-sync-gfid /usr/share/glusterfs/scripts/gsync-sync-gfid
+ fi
+
+ newinitd "${FILESDIR}/${PN}-r1.initd" glusterfsd
+ newinitd "${FILESDIR}/glusterd-r3.initd" glusterd
+ newconfd "${FILESDIR}/${PN}.confd" glusterfsd
+
+ keepdir /var/log/${PN}
+ keepdir /var/lib/glusterd/{events,glusterfind/.keys}
+
+ # QA
+ rm -r "${ED}/var/run/" || die
+ if ! use static-libs; then
+ find "${D}" -type f -name '*.la' -delete || die
+ fi
+}
+
+src_test() {
+ ./run-tests.sh || die
+}
+
+pkg_postinst() {
+ elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
+ elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
+ elog " /etc/init.d/glusterd start"
+ echo
+ elog "For static configurations, the glusterfsd startup script can be multiplexed."
+ elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
+ elog "separate service. To create additional instances of the glusterfsd service"
+ elog "simply create a symlink to the glusterfsd startup script."
+ echo
+ elog "Example:"
+ elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
+ elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
+ elog "You can now treat glusterfsd2 like any other service"
+ echo
+ ewarn "You need to use a ntp client to keep the clocks synchronized across all"
+ ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
+ ewarn "run GlusterFS."
+ echo
+ elog "If you are upgrading from a previous version of ${PN}, please read:"
+ elog " http://docs.gluster.org/en/latest/Upgrade-Guide/upgrade_to_$(ver_cut '1-2')/"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}