summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-08-14 15:40:22 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-08-14 15:41:48 +0300
commit3260bc72f4980f1b9fcf11fb47fcf4b213875522 (patch)
treea3d77b2907efd11274032e1a4753990eb052cdfd /sys-cluster
parentsys-cluster/rdma-core: Drop old (diff)
downloadgentoo-3260bc72f4980f1b9fcf11fb47fcf4b213875522.tar.gz
gentoo-3260bc72f4980f1b9fcf11fb47fcf4b213875522.tar.bz2
gentoo-3260bc72f4980f1b9fcf11fb47fcf4b213875522.zip
sys-cluster/rdma-core: install ibcap init conditionally
Closes: https://bugs.gentoo.org/731806 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/rdma-core/rdma-core-30.0-r2.ebuild (renamed from sys-cluster/rdma-core/rdma-core-30.0-r1.ebuild)5
-rw-r--r--sys-cluster/rdma-core/rdma-core-9999.ebuild15
2 files changed, 14 insertions, 6 deletions
diff --git a/sys-cluster/rdma-core/rdma-core-30.0-r1.ebuild b/sys-cluster/rdma-core/rdma-core-30.0-r2.ebuild
index b3733ae362bb..6d11c3600ccd 100644
--- a/sys-cluster/rdma-core/rdma-core-30.0-r1.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-30.0-r2.ebuild
@@ -93,7 +93,10 @@ src_install() {
udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
rm -r "${D}"/etc/{udev,init.d} || die
- newinitd "${FILESDIR}"/ibacm.init ibacm
+ if use neigh; then
+ newinitd "${FILESDIR}"/ibacm.init ibacm
+ fi
+
newinitd "${FILESDIR}"/iwpmd.init iwpmd
newinitd "${FILESDIR}"/srpd.init srpd
diff --git a/sys-cluster/rdma-core/rdma-core-9999.ebuild b/sys-cluster/rdma-core/rdma-core-9999.ebuild
index 97ce36421f75..6d11c3600ccd 100644
--- a/sys-cluster/rdma-core/rdma-core-9999.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,8 +14,8 @@ if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
else
- SRC_URI="https://github.com/linux-rdma/rdma-core/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~hppa ~x86"
+ SRC_URI="https://github.com/linux-rdma/rdma-core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc x86"
fi
LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
@@ -38,7 +38,7 @@ DEPEND="${COMMON_DEPEND}
)"
RDEPEND="${COMMON_DEPEND}
- !!sys-fabric/infiniband-diags
+ !sys-fabric/infiniband-diags
!sys-fabric/libibverbs
!sys-fabric/librdmacm
!sys-fabric/libibumad
@@ -56,6 +56,8 @@ RDEPEND="${COMMON_DEPEND}
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/optional_pandoc.patch )
+
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -91,7 +93,10 @@ src_install() {
udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
rm -r "${D}"/etc/{udev,init.d} || die
- newinitd "${FILESDIR}"/ibacm.init ibacm
+ if use neigh; then
+ newinitd "${FILESDIR}"/ibacm.init ibacm
+ fi
+
newinitd "${FILESDIR}"/iwpmd.init iwpmd
newinitd "${FILESDIR}"/srpd.init srpd