summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-01 14:14:16 +0100
committerSam James <sam@gentoo.org>2023-05-01 14:19:03 +0100
commit34afa8e8efeaca295954dbf844d9ab46f7b9e2e6 (patch)
treef84faa3a2bd1d3bcd7382c4f822348a3817b68c5 /sys-cluster
parentnet-analyzer/pmacct: drop 1.7.7-r1 (diff)
downloadgentoo-34afa8e8efeaca295954dbf844d9ab46f7b9e2e6.tar.gz
gentoo-34afa8e8efeaca295954dbf844d9ab46f7b9e2e6.tar.bz2
gentoo-34afa8e8efeaca295954dbf844d9ab46f7b9e2e6.zip
sys-cluster/ceph: fix Python dep harder
Fixes: 52f4d1ee90e19550b1a7c5dff230b88ce93b6948 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-16.2.10-r5.ebuild4
-rw-r--r--sys-cluster/ceph/ceph-16.2.12.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-cluster/ceph/ceph-16.2.10-r5.ebuild b/sys-cluster/ceph/ceph-16.2.10-r5.ebuild
index df5c40821102..d2bc739d6664 100644
--- a/sys-cluster/ceph/ceph-16.2.10-r5.ebuild
+++ b/sys-cluster/ceph/ceph-16.2.10-r5.ebuild
@@ -93,7 +93,7 @@ DEPEND="
spdk? ( dev-util/cunit )
sqlite? ( dev-db/sqlite:= )
system-boost? ( dev-libs/boost:=[context,python,${PYTHON_USEDEP},zlib] )
- !system-boost? ( $(python_gen_impl_dep '' 3.9 3.10) )
+ !system-boost? ( $(python_gen_impl_dep '' 3.10 3.11) )
uring? ( sys-libs/liburing:= )
xfs? ( sys-fs/xfsprogs:= )
zbd? ( sys-block/libzbd:= )
@@ -236,7 +236,7 @@ pkg_pretend() {
pkg_setup() {
if ! use system-boost; then
- python_setup 3.8 3.9
+ python_setup 3.10 3.11
else
python_setup
fi
diff --git a/sys-cluster/ceph/ceph-16.2.12.ebuild b/sys-cluster/ceph/ceph-16.2.12.ebuild
index 8051bb4868b4..c5d5962caa2b 100644
--- a/sys-cluster/ceph/ceph-16.2.12.ebuild
+++ b/sys-cluster/ceph/ceph-16.2.12.ebuild
@@ -93,7 +93,7 @@ DEPEND="
spdk? ( dev-util/cunit )
sqlite? ( dev-db/sqlite:= )
system-boost? ( dev-libs/boost:=[context,python,${PYTHON_USEDEP},zlib] )
- !system-boost? ( $(python_gen_impl_dep '' 3.9 3.10) )
+ !system-boost? ( $(python_gen_impl_dep '' 3.10 3.11) )
uring? ( sys-libs/liburing:= )
xfs? ( sys-fs/xfsprogs:= )
zbd? ( sys-block/libzbd:= )
@@ -234,7 +234,7 @@ pkg_pretend() {
pkg_setup() {
if ! use system-boost; then
- python_setup 3.8 3.9
+ python_setup 3.10 3.11
else
python_setup
fi