summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-10 11:24:05 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 12:24:35 +0100
commit423c0ce36d7d382224961f17b19ecf27ced57a84 (patch)
treeebc3c64c42c18cc113a2250f0f4fe6cd8bec850b /sys-cluster
parentgames-emulation/dolphin: drop unused 'versionator' import (diff)
downloadgentoo-423c0ce36d7d382224961f17b19ecf27ced57a84.tar.gz
gentoo-423c0ce36d7d382224961f17b19ecf27ced57a84.tar.bz2
gentoo-423c0ce36d7d382224961f17b19ecf27ced57a84.zip
sys-cluster/fake: Bump to EAPI 7
Closes: https://bugs.gentoo.org/697176 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/fake/fake-1.1.10.ebuild35
1 files changed, 14 insertions, 21 deletions
diff --git a/sys-cluster/fake/fake-1.1.10.ebuild b/sys-cluster/fake/fake-1.1.10.ebuild
index 8d3037b8fbff..3f960e577b00 100644
--- a/sys-cluster/fake/fake-1.1.10.ebuild
+++ b/sys-cluster/fake/fake-1.1.10.ebuild
@@ -1,38 +1,31 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils
-
-DESCRIPTION="Fake has been designed to switch in backup servers on a LAN"
+DESCRIPTION="Switch in backup servers on a LAN"
SRC_URI="http://www.vergenet.net/linux/${PN}/download/${PV}/${P}.tar.gz"
HOMEPAGE="http://www.vergenet.net/linux/fake/"
SLOT="0"
KEYWORDS="~amd64 x86"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_unpack(){
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/fix-ldflags.patch"
-}
+PATCHES=(
+ "${FILESDIR}/fix-ldflags.patch"
+)
-src_compile(){
- make patch || die "patching failed"
- emake || die "make failed"
+src_prepare() {
+ default
+ emake patch
}
src_install(){
emake \
- ROOT_DIR="${D}" \
- MAN8_DIR="${D}/usr/share/man/man8" \
- DOC_DIR="${D}/usr/share/doc/${P}" \
- install || die "install failed"
+ ROOT_DIR="${ED}" \
+ MAN8_DIR="${ED}/usr/share/man/man8" \
+ DOC_DIR="${ED}/usr/share/doc/${PF}" \
+ install
dodoc AUTHORS ChangeLog README docs/*
}