summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-23 21:23:35 +0100
committerSam James <sam@gentoo.org>2021-09-23 21:31:22 +0100
commit4c2a5999e1c81c0fc121361463751f1e034edfdf (patch)
tree28f19abbcaca2598a1d5647ec15e7e936431c6a0 /sys-cluster
parentsys-cluster/mpich: workaround build failure with GCC 10 (diff)
downloadgentoo-4c2a5999e1c81c0fc121361463751f1e034edfdf.tar.gz
gentoo-4c2a5999e1c81c0fc121361463751f1e034edfdf.tar.bz2
gentoo-4c2a5999e1c81c0fc121361463751f1e034edfdf.zip
sys-cluster/mpich2: workaround build failures with GCC 10
Closes: https://bugs.gentoo.org/725722 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/mpich2-1.5.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-cluster/mpich2/mpich2-1.5.ebuild b/sys-cluster/mpich2/mpich2-1.5.ebuild
index f73637a3bb19..9a764592cba5 100644
--- a/sys-cluster/mpich2/mpich2-1.5.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.5.ebuild
@@ -5,7 +5,7 @@ EAPI=5
FORTRAN_NEEDED=fortran
-inherit epatch fortran-2
+inherit epatch fortran-2 flag-o-matic
MY_PV=${PV/_/}
DESCRIPTION="A high performance and portable MPI implementation"
@@ -72,17 +72,25 @@ src_configure() {
c="${c} --enable-threads=single"
fi
+
+ # GCC 10 compatibility workaround
+ # bug #725722
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
export MPICH2LIB_CFLAGS=${CFLAGS}
export MPICH2LIB_CPPFLAGS=${CPPFLAGS}
export MPICH2LIB_CXXFLAGS=${CXXFLAGS}
export MPICH2LIB_FFLAGS=${FFLAGS}
export MPICH2LIB_FCFLAGS=${FCFLAGS}
export MPICH2LIB_LDFLAGS=${LDFLAGS}
- unset CFLAGS CPPFLAGS CXXFLAGS FFLAGS FCFLAGS LDFLAGS
+ # dropped w/ bug #725722 fix
+ #unset CFLAGS CPPFLAGS CXXFLAGS FFLAGS FCFLAGS LDFLAGS
c="${c} --sysconfdir=${EPREFIX}/etc/${PN}"
c="${c} --docdir=${EPREFIX}/usr/share/doc/${PF}"
- econf ${c} \
+
+ # Forcing Bash as there's quite a few bashisms in the build system
+ CONFIG_SHELL="${BROOT}/bin/bash" econf \
--with-pm=hydra \
--disable-mpe \
--disable-fast \