summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-12-13 21:38:15 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-12-13 21:40:22 -0600
commit537f9338ff2c249f8f822a88102246cb371bde34 (patch)
tree404e11254b0f960fd4f00ef4183254d10dce684f /sys-cluster
parentdev-libs/jemalloc - multiple bug fixes and improvements, address missing (diff)
downloadgentoo-537f9338ff2c249f8f822a88102246cb371bde34.tar.gz
gentoo-537f9338ff2c249f8f822a88102246cb371bde34.tar.bz2
gentoo-537f9338ff2c249f8f822a88102246cb371bde34.zip
sys-cluster/swift: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/swift/Manifest1
-rw-r--r--sys-cluster/swift/swift-2.10.1.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/sys-cluster/swift/Manifest b/sys-cluster/swift/Manifest
index 822251b051ae..2ef896ae5069 100644
--- a/sys-cluster/swift/Manifest
+++ b/sys-cluster/swift/Manifest
@@ -1,2 +1,3 @@
DIST swift-2.10.0.tar.gz 1868659 SHA256 8f6f05c1571173dc1c159f74dfe92ac4bb5a0aa3c9adf43fb71c57e643e5e355 SHA512 7f3e3280f0ccc4d3733fc7cf9d4d348f80de4dcd832af8e19c35f04f9ab07afe5eb7af465f20f6a37c8d8b6373ff01d491afdf0cf841949ac0cb0a26c139afb8 WHIRLPOOL d5add284951af467337ce9f856d27d29b491b7fc40df034b7c1350b9a067e2b969bb0a5894ecc4c85a3df267ce746ec05938585408ccec64d82fe28d73db1e07
+DIST swift-2.10.1.tar.gz 1882648 SHA256 11efe34c68a3fee908b434ede79cdb387862e724971b44e9e02083117aea5d95 SHA512 8307ed1f014f502a6e2d63b1b9c28f3229c035e34397a9c5369470085c6e54a9ac33fde0106beee975bd860c4be169f4da7231b7991ab6472596f6c5b614b178 WHIRLPOOL bc010464b00bb8a7eed96767ec7fccb99baf03250ab64728bc712054276b4c2b28e1432bde76687451ebef26663d2f64335f6e90471e2666f7ca207e5acf7f4b
DIST swift-2.9.0.tar.gz 1799896 SHA256 61f786eabb4e4f329def36ee5a58975e8bc18cce2d3007f858f795d3ed52b2f4 SHA512 8d6c62274f09bfe2512b93f8e7c0084e00018b9a3786e8ae9e6bbcc753248611650ddc135fad5af5cd38ab22dd648305fdd54bac20fbe4ae2d4f259de36f9fef WHIRLPOOL 3cc3f8b57b690ff47229eaf17ce70252326b6ae3bf99ad3b0128b9edfa0df16ea5efe91207feeea4cc931f3dc865f7b58ae578868ec0ee503126b87a23612e87
diff --git a/sys-cluster/swift/swift-2.10.1.ebuild b/sys-cluster/swift/swift-2.10.1.ebuild
new file mode 100644
index 000000000000..52716bf282f9
--- /dev/null
+++ b/sys-cluster/swift/swift-2.10.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils linux-info user
+
+DESCRIPTION="A highly available, distributed, and eventually consistent object/blob store"
+HOMEPAGE="https://launchpad.net/swift"
+SRC_URI="https://tarballs.openstack.org/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="proxy account container object +memcached"
+REQUIRED_USE="|| ( proxy account container object )"
+
+CDEPEND="
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+
+RDEPEND="
+ ${CDEPEND}
+ virtual/python-dnspython[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.17.4[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.5[${PYTHON_USEDEP}]
+ !~dev-python/netifaces-0.10.0[${PYTHON_USEDEP}]
+ !~dev-python/netifaces-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/pyxattr[${PYTHON_USEDEP}]
+ >=dev-python/PyECLib-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.0[${PYTHON_USEDEP}]
+ !~dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
+ memcached? ( net-misc/memcached )
+ net-misc/rsync[xattr]"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
+ ~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
+ ~ZFS"
+ if linux_config_exists; then
+ for module in ${CONFIG_CHECK}; do
+ linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled"
+ done
+ fi
+}
+
+pkg_setup() {
+ enewuser swift
+ enewgroup swift
+}
+
+src_prepare() {
+ sed -i 's/xattr/pyxattr/g' swift.egg-info/requires.txt || die
+ sed -i 's/xattr/pyxattr/g' requirements.txt || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+src_test () {
+ # https://bugs.launchpad.net/swift/+bug/1249727
+ find . \( -name test_wsgi.py -o -name test_locale.py -o -name test_utils.py \) -delete || die
+ SKIP_PIP_INSTALL=1 PBR_VERSION=0.6.0 sh .unittests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ keepdir /etc/swift
+ insinto /etc/swift
+
+ newins "etc/swift.conf-sample" "swift.conf"
+ newins "etc/rsyncd.conf-sample" "rsyncd.conf"
+ newins "etc/mime.types-sample" "mime.types-sample"
+ newins "etc/memcache.conf-sample" "memcache.conf-sample"
+ newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
+ newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
+
+ if use proxy; then
+ newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
+ newins "etc/proxy-server.conf-sample" "proxy-server.conf"
+ if use memcached; then
+ sed -i '/depend/a\
+ need memcached' "${D}/etc/init.d/swift-proxy"
+ fi
+ fi
+ if use account; then
+ newinitd "${FILESDIR}/swift-account.initd" "swift-account"
+ newins "etc/account-server.conf-sample" "account-server.conf"
+ fi
+ if use container; then
+ newinitd "${FILESDIR}/swift-container.initd" "swift-container"
+ newins "etc/container-server.conf-sample" "container-server.conf"
+ fi
+ if use object; then
+ newinitd "${FILESDIR}/swift-object.initd" "swift-object"
+ newins "etc/object-server.conf-sample" "object-server.conf"
+ newins "etc/object-expirer.conf-sample" "object-expirer.conf"
+ fi
+
+ fowners swift:swift "/etc/swift" || die "fowners failed"
+}
+
+pkg_postinst() {
+ elog "Openstack swift will default to using insecure http unless a"
+ elog "certificate is created in /etc/swift/cert.crt and the associated key"
+ elog "in /etc/swift/cert.key. These can be created with the following:"
+ elog " * cd /etc/swift"
+ elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
+}