summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-29 12:02:18 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-29 12:02:18 +0100
commit59c64f758812d6989adc97939863b41178e48348 (patch)
treeeed70684b0d73857a2bc9cdc1b5e30b3abfa0255 /sys-cluster
parentdev-python/fitsio: add 1.1.7, ebuild cleanup, fix license (diff)
downloadgentoo-59c64f758812d6989adc97939863b41178e48348.tar.gz
gentoo-59c64f758812d6989adc97939863b41178e48348.tar.bz2
gentoo-59c64f758812d6989adc97939863b41178e48348.zip
sys-cluster/rdma-core: fix build on musl
Closes: https://bugs.gentoo.org/828894 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/rdma-core/files/rdma-core-38.0-musl.patch30
-rw-r--r--sys-cluster/rdma-core/rdma-core-38.0.ebuild2
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-cluster/rdma-core/files/rdma-core-38.0-musl.patch b/sys-cluster/rdma-core/files/rdma-core-38.0-musl.patch
new file mode 100644
index 000000000000..b3f92bfaa1a3
--- /dev/null
+++ b/sys-cluster/rdma-core/files/rdma-core-38.0-musl.patch
@@ -0,0 +1,30 @@
+From cf11c3d888ae49374ed2d4871560c82e4639b85b Mon Sep 17 00:00:00 2001
+From: David Seifert <soap@gentoo.org>
+Date: Sat, 29 Jan 2022 11:57:38 +0100
+Subject: [PATCH] Do not use `__THROW` in prototypes
+
+`__THROW` is a glibc-internal macro, as indicated by the
+preceding double underscore. The absence of this macro breaks
+builds on musl.
+
+Bug: https://bugs.gentoo.org/828894
+---
+ libibverbs/neigh.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libibverbs/neigh.c b/libibverbs/neigh.c
+index fa3cbf57..7eed95f1 100644
+--- a/libibverbs/neigh.c
++++ b/libibverbs/neigh.c
+@@ -30,7 +30,7 @@
+ #if !HAVE_WORKING_IF_H
+ /* We need this decl from net/if.h but old systems do not let use co-include
+ net/if.h and netlink/route/link.h */
+-extern unsigned int if_nametoindex(__const char *__ifname) __THROW;
++extern unsigned int if_nametoindex(__const char *__ifname);
+ #endif
+
+ /* for PFX */
+--
+2.35.0
+
diff --git a/sys-cluster/rdma-core/rdma-core-38.0.ebuild b/sys-cluster/rdma-core/rdma-core-38.0.ebuild
index d25ddc3d8951..413f2aac21ed 100644
--- a/sys-cluster/rdma-core/rdma-core-38.0.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-38.0.ebuild
@@ -56,6 +56,8 @@ RDEPEND="${COMMON_DEPEND}
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/${P}-musl.patch )
+
pkg_setup() {
use python && python-single-r1_pkg_setup