summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Ten Harmsel <alec@alectenharmsel.com>2020-04-14 08:30:30 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-04-16 11:09:49 +0300
commit5efbbd6fcecfe6cc7bef5e87b8c4ddf8758ca6b9 (patch)
treea8428de61c2183393a9a4583a283af7086cd122a /sys-cluster
parentnet-misc/youtube-viewer: Drop outdated testing 3.5.9 version (diff)
downloadgentoo-5efbbd6fcecfe6cc7bef5e87b8c4ddf8758ca6b9.tar.gz
gentoo-5efbbd6fcecfe6cc7bef5e87b8c4ddf8758ca6b9.tar.bz2
gentoo-5efbbd6fcecfe6cc7bef5e87b8c4ddf8758ca6b9.zip
sys-cluster/spark-bin: Bump to 2.4.5
Bug: https://bugs.gentoo.org/670670 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alec Ten Harmsel <alec@alectenharmsel.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/spark-bin/Manifest1
-rw-r--r--sys-cluster/spark-bin/spark-bin-2.4.5.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-cluster/spark-bin/Manifest b/sys-cluster/spark-bin/Manifest
index bf58b8436148..1fd3bfeeed8b 100644
--- a/sys-cluster/spark-bin/Manifest
+++ b/sys-cluster/spark-bin/Manifest
@@ -1,2 +1,3 @@
DIST spark-bin-2.3.1.tgz 225883783 BLAKE2B d89e83a54aaabd39c5fa0d9c51a1bb5635f60ded4869672a387d13d87fffbb48385d4fbf67b55a96e709f27348f73a089624a0563c98eaba31f93d74bf4548ee SHA512 dc3a97f3d99791d363e4f70a622b84d6e313bd852f6fdbc777d31eab44cbc112ceeaa20f7bf835492fb654f48ae57e9969f93d3b0e6ec92076d1c5e1b40b4696
DIST spark-bin-2.4.4.tgz 230091034 BLAKE2B 66f7e7bae6fe6959f233adc085560cf1b80a641b4018eb334d77f390eb88f5ab898e1ea59c1c17ca15a122f4f98eea4670ea7152bc2c83f6cb76cd11d3f586ec SHA512 2e3a5c853b9f28c7d4525c0adcb0d971b73ad47d5cce138c85335b9f53a6519540d3923cb0b5cee41e386e49ae8a409a51ab7194ba11a254e037a848d0c4a9e5
+DIST spark-bin-2.4.5.tgz 232530699 BLAKE2B e67d728af9e40417afb09e342d515021146bebef9a27df12cab2b64f1eb3ed134bbb8eecd731b2e30c9c4c6042f6fb9d076da5ac5c654c9066d2f9c3ecd0c24c SHA512 2426a20c548bdfc07df288cd1d18d1da6b3189d0b78dee76fa034c52a4e02895f0ad460720c526f163ba63a17efae4764c46a1cd8f9b04c60f9937a554db85d2
diff --git a/sys-cluster/spark-bin/spark-bin-2.4.5.ebuild b/sys-cluster/spark-bin/spark-bin-2.4.5.ebuild
new file mode 100644
index 000000000000..c178519a3a77
--- /dev/null
+++ b/sys-cluster/spark-bin/spark-bin-2.4.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2
+
+DESCRIPTION="Lightning-fast unified analytics engine"
+HOMEPAGE="https://spark.apache.org"
+SRC_URI="mirror://apache/spark/spark-${PV}/spark-${PV}-bin-hadoop2.7.tgz -> ${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=virtual/jre-1.8"
+
+DEPEND="
+ >=virtual/jdk-1.8"
+
+S="${WORKDIR}/spark-${PV}-bin-hadoop2.7"
+
+DOCS=( LICENSE NOTICE README.md RELEASE )
+
+# Nothing to compile here.
+src_compile() { :; }
+
+src_install() {
+ dodir usr/lib/spark
+ into usr/lib/spark
+
+ dobin bin/beeline \
+ bin/find-spark-home \
+ bin/pyspark \
+ bin/spark-class \
+ bin/spark-shell \
+ bin/spark-sql \
+ bin/spark-submit
+
+ insinto usr/lib/spark/bin
+ doins bin/load-spark-env.sh
+
+ insinto usr/lib/spark
+ doins -r conf
+ doins -r jars
+ doins -r python
+ doins -r sbin
+ doins -r yarn
+
+ dosym ../lib/spark/bin/beeline /usr/bin/beeline
+ dosym ../lib/spark/bin/find-spark-home /usr/bin/find-spark-home
+ dosym ../lib/spark/bin/pyspark /usr/bin/pyspark
+ dosym ../lib/spark/bin/spark-class /usr/bin/spark-class
+ dosym ../lib/spark/bin/spark-shell /usr/bin/spark-shell
+ dosym ../lib/spark/bin/spark-sql /usr/bin/spark-sql
+ dosym ../lib/spark/bin/spark-submit /usr/bin/spark-submit
+
+ doenvd "${FILESDIR}"/99spark
+ einstalldocs
+}