summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-09-18 19:37:02 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-09-21 10:03:04 +0300
commit5eff66355fe428821c86076e54d542b94cd3b8db (patch)
treefac835226183de8dd8f38c8eae9d205d5337b97a /sys-cluster
parentnet-p2p/go-ethereum: vulnerability hotfix, 1.10.8 bump (diff)
downloadgentoo-5eff66355fe428821c86076e54d542b94cd3b8db.tar.gz
gentoo-5eff66355fe428821c86076e54d542b94cd3b8db.tar.bz2
gentoo-5eff66355fe428821c86076e54d542b94cd3b8db.zip
sys-cluster/charliecloud: Bump to version 0.25.
This unbundles dev-python/lark-parser which is now bundled upstream by default, and adds python 3.10 compatibility. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.25.ebuild78
-rw-r--r--sys-cluster/charliecloud/charliecloud-9999.ebuild4
3 files changed, 82 insertions, 1 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index f67be3cd9335..861b1cca2fed 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,2 +1,3 @@
DIST charliecloud-0.23.tar.gz 403281 BLAKE2B f7a6824782e7bf3bdb51ae791fdca2f5929f5c713590ff49cc8a7e1e1c1758e83bdd429a99497dd15e565d01f0f66f2873f64edddacf24ea78f68c2326669db7 SHA512 35543ed3d838b80fbb64fe3e658993fe9f7ded2d1dfd92e0e9a7725fab6d872503a790964c0f3fabb6438c8bd872b5b00cdf31a028f26588b318b9d0dc568119
DIST charliecloud-0.24.tar.gz 420852 BLAKE2B ca55231c74012a678c24133b28e341392865a562653086766e6b5e570744f31ce69d1afa2bbb2cc85d5e52b6ed6e9f42f67187d9998afd3852a10fd4a8ff29d3 SHA512 41f44ef5f12dc35d7972923a84044b7255801705d4fcabf76e675dcb70a9f25422e7d584a7b49135ef2ae5dc1751a39efd84f8eb719653a769b41f46bd558fd2
+DIST charliecloud-0.25.tar.gz 454041 BLAKE2B 3a071f3b9fb06ca1db6d3b85a577943fe76440d395fdf1415d5085110db665fb75ee09dc14768d326e7e280e6c20096479e5f62290f7dee46821c356f5f18535 SHA512 a7a35b584dbdd6c6e27188d3555173c44f90c0e44fa685a15a47f47c94f9d76aa46ab80054a7c53e10a7f56bef87696f1db2a0eb8c49a388dbb0da0fe9112a60
diff --git a/sys-cluster/charliecloud/charliecloud-0.25.ebuild b/sys-cluster/charliecloud/charliecloud-0.25.ebuild
new file mode 100644
index 000000000000..747ab7795f94
--- /dev/null
+++ b/sys-cluster/charliecloud/charliecloud-0.25.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit autotools optfeature python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x86-linux"
+fi
+
+DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
+HOMEPAGE="https://hpc.github.io/charliecloud/"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+IUSE="ch-image doc"
+
+# Extensive test suite exists, but downloads container images
+# directly and via Docker and installs packages inside using apt/yum.
+# Additionally, clashes with portage namespacing and sandbox.
+RESTRICT="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="
+ ch-image? (
+ $(python_gen_cond_dep '
+ dev-python/lark-parser[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ )
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ ')
+ net-misc/rsync
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local econf_args=()
+ econf_args+=(
+ $(use_enable doc html)
+ $(use_enable ch-image)
+ # Libdir is used as a libexec-style destination.
+ --libdir="${EPREFIX}"/usr/lib
+ # Attempts to call python-exec directly otherwise.
+ --with-sphinx-python=${PYTHON}
+ # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
+ --enable-buggy-build
+ # Do not use bundled version of dev-python/lark-parser.
+ --disable-bundled-lark
+ )
+ econf "${econf_args[@]}"
+}
+
+pkg_postinst() {
+ elog "Various builders are supported, as alternative to the internal ch-image."
+ optfeature "Building with Buildah" app-emulation/buildah
+ optfeature "Building with Docker" app-emulation/docker
+ optfeature "Progress bars during long operations" sys-apps/pv
+ optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
+ optfeature "Mount and umount squashfs images" sys-fs/squashfuse
+}
diff --git a/sys-cluster/charliecloud/charliecloud-9999.ebuild b/sys-cluster/charliecloud/charliecloud-9999.ebuild
index 20ef1b5db540..747ab7795f94 100644
--- a/sys-cluster/charliecloud/charliecloud-9999.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
inherit autotools optfeature python-single-r1
@@ -62,6 +62,8 @@ src_configure() {
--with-sphinx-python=${PYTHON}
# This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
--enable-buggy-build
+ # Do not use bundled version of dev-python/lark-parser.
+ --disable-bundled-lark
)
econf "${econf_args[@]}"
}