summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-09 23:07:38 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-09 23:18:14 +0100
commit7ab3d4434cd5456617454571c6f5051508593700 (patch)
tree7fbaa04dd0b747c858946652f59b53c53cb23dc8 /sys-cluster
parentsys-cluster/c3: Bump to EAPI 7 (diff)
downloadgentoo-7ab3d4434cd5456617454571c6f5051508593700.tar.gz
gentoo-7ab3d4434cd5456617454571c6f5051508593700.tar.bz2
gentoo-7ab3d4434cd5456617454571c6f5051508593700.zip
sys-cluster/cman-lib: Bump to EAPI 7
Bug: https://bugs.gentoo.org/697176 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild37
1 files changed, 17 insertions, 20 deletions
diff --git a/sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild b/sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild
index b3b168af577e..3bf3a08a2cd9 100644
--- a/sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild
+++ b/sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils versionator multilib
+inherit toolchain-funcs
MY_P=cluster-${PV}
-
-MAJ_PV=$(get_major_version)
-MIN_PV=$(get_version_component_range 2).$(get_version_component_range 3)
+MAJ_PV=$(ver_cut 1)
+MIN_PV=$(ver_cut 2-3)
DESCRIPTION="A library for cluster management common to the various pieces of Cluster Suite"
HOMEPAGE="https://sourceware.org/cluster/wiki/"
@@ -26,23 +25,21 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}/${PN/-//}
-src_compile() {
- (cd "${WORKDIR}"/${MY_P};
- ./configure \
- --cc="$(tc-getCC)" \
- --libdir=/usr/$(get_libdir) \
- --cflags="-Wall" \
- --disable_kernel_check \
- --somajor="$MAJ_PV" \
- --sominor="$MIN_PV" \
- ) || die "configure problem"
+src_configure() {
+ cd "${WORKDIR}"/${MY_P} || die
+ ./configure \
+ --cc="$(tc-getCC)" \
+ --libdir=/usr/$(get_libdir) \
+ --cflags="-Wall" \
+ --disable_kernel_check \
+ --somajor="$MAJ_PV" \
+ --sominor="$MIN_PV" \
+ || die "configure problem"
sed -e 's:\($(CC)\):\1 $(LDFLAGS):' \
-i Makefile "${WORKDIR}/${MY_P}/make/cobj.mk" || die
-
- emake clean all || die
}
-src_install() {
- emake DESTDIR="${D}" install || die
+src_compile() {
+ emake clean all
}