summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-03-21 12:03:41 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-03-21 12:04:44 -0500
commit967b3a58975b238622e79abafd7e83bae289c99e (patch)
tree87be3c4a85b70a93a11a134cf6cf5d43967bbaa2 /sys-cluster
parentdev-python/jaraco-text: Use PYPI_PN (diff)
downloadgentoo-967b3a58975b238622e79abafd7e83bae289c99e.tar.gz
gentoo-967b3a58975b238622e79abafd7e83bae289c99e.tar.bz2
gentoo-967b3a58975b238622e79abafd7e83bae289c99e.zip
sys-cluster/k9scli: add 0.27.3
Thanks to Jason Hollis for bringing this to my attention. Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/k9scli/Manifest2
-rw-r--r--sys-cluster/k9scli/k9scli-0.27.3.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-cluster/k9scli/Manifest b/sys-cluster/k9scli/Manifest
index 75c5c00959ab..3e98777b04ce 100644
--- a/sys-cluster/k9scli/Manifest
+++ b/sys-cluster/k9scli/Manifest
@@ -1,2 +1,4 @@
DIST k9scli-0.25.18-vendor.tar.xz 7994460 BLAKE2B bbe0d1184ddfcc696136de86949a4fcca99f84dbdccdc32d7f49956f5fca6839e6bf87e09499a9b4e905b5730d70d3c73bb7664e82116af88bb81de2613004fd SHA512 fec937e77d3bb0d72e1ca07a3e1c654a37d2201d78f9deb74168c0ccda8d4fb19f961fef5a78c4e4ee0280a103e0ba8c7848212844562cec80904d7f12def388
DIST k9scli-0.25.18.tar.gz 6407574 BLAKE2B 15a6ddc86e3531774d0a074a670ded26ce506f847de6a7ebd507b0d77dcd03921b1f46372b5c17e46be60016e285c315c3749842143f5e299459ba9b5c6b938a SHA512 e295fd63b8e166da626f81cde3ef3d5e195448d1017958ed40293d7161d20ed3730151b375ddb5036da958197b43f6b236b8f3575754972cd77ad7afa60ccf4a
+DIST k9scli-0.27.3-deps.tar.xz 180543948 BLAKE2B bcd3d26a799d4ab2ac43b854e278c67f1616a2f98041f4727f961342690567437b1eef980413d5ee5c654a0c846c927563fb55a397f38ae1a378d83e30cf041b SHA512 ad1697b9faccdb38911d379c5c8b2bddfac20fba48f4e28247b6f6669f22179baec11c6cc76df83afdcf321a4fd1452ff9105718f3e51a29772659ae5d8ded98
+DIST k9scli-0.27.3.tar.gz 6395143 BLAKE2B 2b9db72656cac4798909c84732f1be1c43628c24e6442d2e100c235cd315d741be610a91b38bd22463e06716f4c1bcd4b44bdd3b598e8cbb7be2339407df1197 SHA512 ce42e49ae40ddb57e0105637a58f47c91b0efe284151da460f4bf74a52bdb3a6572c4ff7859430677dbd1aad715d132a4b92ac71abbd76a97135fdb3fdd3f3f8
diff --git a/sys-cluster/k9scli/k9scli-0.27.3.ebuild b/sys-cluster/k9scli/k9scli-0.27.3.ebuild
new file mode 100644
index 000000000000..5d9a8dfee490
--- /dev/null
+++ b/sys-cluster/k9scli/k9scli-0.27.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+# update this on every bump
+GIT_COMMIT=7c76691c
+
+DESCRIPTION="terminal based UI to manage kubernetes clusters"
+HOMEPAGE="https://k9scli.io"
+SRC_URI="https://github.com/derailed/k9s/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/k9s-${PV}"
+
+src_prepare() {
+ default
+ # I will look into opening an upstream PR to do this.
+ sed -i -e 's/-w -s -X/-X/' Makefile || die
+}
+
+src_compile() {
+ emake GIT=${GIT_COMMIT} VERSION=v${PV} build
+}
+
+src_install() {
+ dobin execs/k9s
+ dodoc -r change_logs plugins skins README.md
+}