summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-11-29 22:55:51 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-11-29 23:18:10 -0600
commit9686ff9b3c3e09c8c8504ae2a9fa6f8afba0e8c8 (patch)
tree18b1b8cab09964a53fca0596ad4ab83429ec8f1b /sys-cluster
parentsci-geosciences/grass: use wxGTK:3.0 per #600986 (diff)
downloadgentoo-9686ff9b3c3e09c8c8504ae2a9fa6f8afba0e8c8.tar.gz
gentoo-9686ff9b3c3e09c8c8504ae2a9fa6f8afba0e8c8.tar.bz2
gentoo-9686ff9b3c3e09c8c8504ae2a9fa6f8afba0e8c8.zip
sys-cluster/cinder: use pkg_pretend for module checking, use python_install_all
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/cinder/cinder-2016.2.9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-cluster/cinder/cinder-2016.2.9999.ebuild b/sys-cluster/cinder/cinder-2016.2.9999.ebuild
index 39ffd3083c53..7332681e78d7 100644
--- a/sys-cluster/cinder/cinder-2016.2.9999.ebuild
+++ b/sys-cluster/cinder/cinder-2016.2.9999.ebuild
@@ -124,7 +124,7 @@ RDEPEND="
#PATCHES=(
#)
-pkg_setup() {
+pkg_pretend() {
linux-info_pkg_setup
CONFIG_CHECK_MODULES=""
if use tcp; then
@@ -141,6 +141,9 @@ pkg_setup() {
linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled"
done
fi
+}
+
+pkg_setup() {
enewgroup cinder
enewuser cinder -1 -1 /var/lib/cinder cinder
}
@@ -155,8 +158,8 @@ python_test() {
nosetests -I test_wsgi.py cinder/tests/ || die "tests failed under python2.7"
}
-python_install() {
- distutils-r1_python_install
+python_install_all() {
+ distutils-r1_python_install_all
keepdir /etc/cinder
dodir /etc/cinder/rootwrap.d