summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2020-11-12 18:08:46 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2020-11-12 18:09:20 +0100
commit9bbe57c855191d1f906a6ef7a0f881817cbdd6cc (patch)
treef2efe0075ab9c209dcfa5176c222a49ddc8c08fb /sys-cluster
parentnet-irc/znc: Stabilize 1.8.2 amd64, #753395 (diff)
downloadgentoo-9bbe57c855191d1f906a6ef7a0f881817cbdd6cc.tar.gz
gentoo-9bbe57c855191d1f906a6ef7a0f881817cbdd6cc.tar.bz2
gentoo-9bbe57c855191d1f906a6ef7a0f881817cbdd6cc.zip
sys-cluster/corosync: bump version, add new features
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/corosync/Manifest2
-rw-r--r--sys-cluster/corosync/corosync-3.1.0.ebuild (renamed from sys-cluster/corosync/corosync-3.0.4.ebuild)40
-rw-r--r--sys-cluster/corosync/metadata.xml4
3 files changed, 39 insertions, 7 deletions
diff --git a/sys-cluster/corosync/Manifest b/sys-cluster/corosync/Manifest
index f5b0f6e764ad..190266919750 100644
--- a/sys-cluster/corosync/Manifest
+++ b/sys-cluster/corosync/Manifest
@@ -1,3 +1,3 @@
DIST corosync-2.3.5.tar.gz 428253 BLAKE2B be9fc2b27b60357acee6dee013bc95c08045c114acafc62eaa82a1821f07ff76b8821b9d06f31246b9978f8aef46e3a9e1a2d61ca74465bc74d4140c0ad0d0fa SHA512 212a95d8a68a2941f27c9ec22750a88598744d6fd4db6b46abe0b4cdfa988d3906f760bdf67c403d8c6d0a04da64f29ec744fb68ca51c7269ba58e306553cee9
DIST corosync-2.4.2.tar.gz 547204 BLAKE2B 1b440e84b25263ea866bd66f9837a3bdbbc790d26a38d10a033d67bb0ba48dd58d6b515879dd0ece75ffe78c8a150c1e5ab8d0eb312e701abdc36eb5cb4dc520 SHA512 45a4d2570d5d096e6f42070f701fdb2aaed26812b6a75f73ea415cf409b33343f8bc090b4fcf851ab971ca4b17925f239c31a3d9eafe4841dfbeb56537b2c78c
-DIST corosync-3.0.4.tar.gz 437582 BLAKE2B a37a3d1543943a76bfff2a11ea62c6fc1dfef3bb7c18fe946c7417d68a4122a6ed13035b0342b65bf1a3f8f8fb4536926b4a9864c8a3c5726f9fde32ab4fca0a SHA512 5ff2e4905d309d25a35aaf3df8081b5bc76eac25b526118e833b5e7af7b440f9d84804352cd283f3c46342e8cb337e460e06d53e58c4302c940405c76e64ade7
+DIST corosync-3.1.0.tar.gz 447073 BLAKE2B 1a0d5b744ac5cba1d67fed6d58a159d8dfc63615aa6fbe5051b20f6e41da589871b6d0b59937db0ac31b4186e4f051378e48308ffc3e0743a5372e494485b3c7 SHA512 05be0d417f3ebbba993b92074f261dea3d951e20d2054817b9017eb04a8a017c9c3f3d0119dafd689944accb690beaafc9f11c1e67f53d978918ea49e51a5e6f
diff --git a/sys-cluster/corosync/corosync-3.0.4.ebuild b/sys-cluster/corosync/corosync-3.1.0.ebuild
index 82dcdda380bb..0c6e68cf61c7 100644
--- a/sys-cluster/corosync/corosync-3.0.4.ebuild
+++ b/sys-cluster/corosync/corosync-3.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools
+inherit linux-info autotools
DESCRIPTION="OSI Certified implementation of a complete cluster engine"
HOMEPAGE="http://www.corosync.org/"
@@ -12,17 +12,16 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2 public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="doc systemd xml dbus"
+IUSE="augeas dbus doc snmp systemd watchdog xml"
-# TODO: support those new configure flags
-# --enable-augeas : Install the augeas lens for corosync.conf
-# --enable-snmp : SNMP protocol support
-# --enable-watchdog : Watchdog support
RDEPEND="dev-libs/nss
>=sys-cluster/libqb-2.0.0:=
sys-cluster/kronosnet:=
+ augeas? ( app-admin/augeas )
dbus? ( sys-apps/dbus )
+ snmp? ( net-analyzer/net-snmp )
systemd? ( sys-apps/systemd:= )
+ watchdog? ( sys-kernel/linux-headers )
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig
@@ -30,6 +29,24 @@ BDEPEND="virtual/pkgconfig
DOCS=( README.recovery AUTHORS )
+pkg_setup() {
+ if use watchdog; then
+ # verify that CONFIG_WATCHDOG is enabled in the kernel or
+ # warn otherwise
+ linux-info_pkg_setup
+ elog "Checking for suitable kernel configuration options..."
+ if linux_config_exists; then
+ if ! linux_chkconfig_present WATCHDOG; then
+ ewarn "CONFIG_WATCHDOG: is not set when it should be."
+ elog "Please check to make sure these options are set correctly."
+ fi
+ else
+ ewarn "Could not check, if CONFIG_WATCHDOG is enabled in your kernel."
+ elog "Please check to make sure these options are set correctly."
+ fi
+ fi
+}
+
src_prepare() {
default
@@ -48,8 +65,11 @@ src_configure() {
econf_opts=(
--disable-static \
--localstatedir=/var \
+ $(use_enable augeas) \
$(use_enable dbus) \
+ $(use_enable snmp) \
$(use_enable systemd) \
+ $(use_enable watchdog) \
$(use_enable xml xmlconf)
)
use doc && econf_opts+=( --enable-doc )
@@ -67,3 +87,11 @@ src_install() {
find "${D}" -name '*.la' -delete || die
}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]]; then
+ elog "Default token timeout was changed from 1 seconds to 3 seconds."
+ elog "If you need to keep the old timeout, add 'token: 1000' to the"
+ elog "totem {} section of your corosync.conf"
+ fi
+}
diff --git a/sys-cluster/corosync/metadata.xml b/sys-cluster/corosync/metadata.xml
index 9f947509ce3a..827c977ca3db 100644
--- a/sys-cluster/corosync/metadata.xml
+++ b/sys-cluster/corosync/metadata.xml
@@ -12,4 +12,8 @@
<upstream>
<remote-id type="github">corosync/corosync</remote-id>
</upstream>
+ <use>
+ <flag name="augeas">Enable augeas support</flag>
+ <flag name="watchdog">Enable watchdog support</flag>
+ </use>
</pkgmetadata>