summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-30 21:44:53 +0000
committerSam James <sam@gentoo.org>2021-03-30 21:45:46 +0000
commitd7c62fe7c2b60209e25aec8da5779df8b4161028 (patch)
treef2af9c6bb38b48380c97608bb29ac79f7e24c4de /sys-cluster
parentdev-dotnet/gtk-sharp: port to EAPI 7, drop base.eclass (diff)
downloadgentoo-d7c62fe7c2b60209e25aec8da5779df8b4161028.tar.gz
gentoo-d7c62fe7c2b60209e25aec8da5779df8b4161028.tar.bz2
gentoo-d7c62fe7c2b60209e25aec8da5779df8b4161028.zip
sys-cluster/vzctl: port to EAPI 7, drop {eutils, base}.eclass, add optfeature
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/vzctl-4.9.4.ebuild69
1 files changed, 33 insertions, 36 deletions
diff --git a/sys-cluster/vzctl/vzctl-4.9.4.ebuild b/sys-cluster/vzctl/vzctl-4.9.4.ebuild
index 97b9d64eb6e1..7c9536d71828 100644
--- a/sys-cluster/vzctl/vzctl-4.9.4.ebuild
+++ b/sys-cluster/vzctl/vzctl-4.9.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit base bash-completion-r1 eutils toolchain-funcs udev
+inherit bash-completion-r1 toolchain-funcs optfeature udev
DESCRIPTION="OpenVZ ConTainers control utility"
HOMEPAGE="http://openvz.org/"
@@ -14,31 +14,35 @@ SLOT="0"
KEYWORDS="amd64 ~ppc64 x86"
IUSE="+ploop +vzmigrate"
-RDEPEND="net-firewall/iptables
- sys-apps/ed
- >=sys-apps/iproute2-3.3.0
- >=sys-fs/vzquota-3.1
- ploop? (
- >=sys-cluster/ploop-1.13
- sys-block/parted
- sys-fs/quota
- dev-libs/libxml2
- )
- >=dev-libs/libcgroup-0.38
- vzmigrate? (
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ >=dev-libs/libcgroup-0.38
+ net-firewall/iptables
+ sys-apps/attr
+ sys-apps/ed
+ >=sys-apps/iproute2-3.3.0
+ >=sys-fs/vzquota-3.1
+ virtual/udev
+ ploop? (
+ dev-libs/libxml2
+ sys-block/parted
+ >=sys-cluster/ploop-1.13
+ sys-fs/quota
+ )
+ vzmigrate? (
+ app-arch/tar[xattr,acl]
net-misc/openssh
net-misc/rsync[xattr,acl]
- app-arch/tar[xattr,acl]
net-misc/bridge-utils
virtual/awk
- )
- virtual/udev
- sys-apps/attr
- "
+ )
+"
+DEPEND="${RDEPEND}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- "
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc225.patch
+ "${FILESDIR}"/${P}-glibc225-2.patch
+)
src_prepare() {
# Set default OSTEMPLATE on gentoo
@@ -46,13 +50,10 @@ src_prepare() {
# Set proper udev directory
sed -i -e "s:/lib/udev:$(get_udevdir):" src/lib/dev.c || die 'sed on src/lib/dev.c failed'
- epatch "${FILESDIR}/${P}-glibc225.patch"
- epatch "${FILESDIR}/${P}-glibc225-2.patch"
- epatch_user
+ default
}
src_configure() {
-
econf \
--localstatedir=/var \
--enable-udev \
@@ -64,11 +65,10 @@ src_configure() {
}
src_install() {
-
emake DESTDIR="${D}" udevdir="$(get_udevdir)"/rules.d install install-gentoo
# install the bash-completion script into the right location
- rm -rf "${ED}"/etc/bash_completion.d
+ rm -rf "${ED}"/etc/bash_completion.d || die
newbashcomp etc/bash_completion.d/vzctl.sh ${PN}
# We need to keep some dirs
@@ -77,12 +77,9 @@ src_install() {
}
pkg_postinst() {
- einfo "This vzctl release required kernel above 2.6.32.92"
-
- einfo "If you have checkpoint suspend/restore feature in vanilla kernel"
- einfo "please install "sys-process/criu" "
- einfo "This is experimental and not stable ( in gentoo ) now"
+ einfo "This vzctl release requires a kernel above 2.6.32.92"
- einfo "if you have work with .xz compressed template, please install app-arch/xz-utils"
- einfo "if you have check signature downloaded template - install gpg "
+ optfeature "Checkpoint suspend/restore support (experimental)" sys-process/criu
+ optfeature "Compressed .xz templates" app-arch/xz-utils
+ optfeature "Signed templates" app-crypt/gnupg
}