summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2023-08-16 21:29:17 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-09-16 10:57:16 +0300
commitd8872845a6d254f29bbc6797e64351d7703ff0b3 (patch)
tree6f1d26b4aba9981dd338c475370b83943a4ce762 /sys-cluster
parentsys-cluster/hpx: add 1.9.1 (diff)
downloadgentoo-d8872845a6d254f29bbc6797e64351d7703ff0b3.tar.gz
gentoo-d8872845a6d254f29bbc6797e64351d7703ff0b3.tar.bz2
gentoo-d8872845a6d254f29bbc6797e64351d7703ff0b3.zip
sys-cluster/hpx: drop 1.9.0
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/hpx/Manifest1
-rw-r--r--sys-cluster/hpx/hpx-1.9.0.ebuild105
2 files changed, 0 insertions, 106 deletions
diff --git a/sys-cluster/hpx/Manifest b/sys-cluster/hpx/Manifest
index 8f98259e438f..5899fb6e1134 100644
--- a/sys-cluster/hpx/Manifest
+++ b/sys-cluster/hpx/Manifest
@@ -1,2 +1 @@
-DIST hpx-1.9.0.tar.gz 5648944 BLAKE2B 642fa16e97954973715bbd87b242b1f7ed13c64dfcffb00f50d7826dd114b3908a350b87508b9b6fde66df8fd772ae1b501f209bc200e3331312c0cc4ab88e80 SHA512 a9b55999e0d9f79433a44f0f7f21340e947fa0ba354ecb007340664a0f4820be1f7723075d18775a395a455648bbb4bff85061e6f7ad4b551b93943e845d4443
DIST hpx-1.9.1.tar.gz 5662661 BLAKE2B 81631333b8899a7271e8c6edf587d0a3afadde28f2605ac4f8ff6ddc3fa5afb5ad8d05818ae6d0bfa8fb7241d3aebfe5f838b85b77f54327010308b22b4900b7 SHA512 a7972beada950cf6ef3b61f20496a08b220e4f48c28c11d57c20683906ca5124a9f36ac2552318883a5ab1db6efdbf63d1141b6e0c484c560a8c1311ae2d7090
diff --git a/sys-cluster/hpx/hpx-1.9.0.ebuild b/sys-cluster/hpx/hpx-1.9.0.ebuild
deleted file mode 100644
index 2418f19d261f..000000000000
--- a/sys-cluster/hpx/hpx-1.9.0.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
-else
- SRC_URI="https://github.com/STEllAR-GROUP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-inherit check-reqs cmake multiprocessing python-single-r1
-
-DESCRIPTION="C++ runtime system for parallel and distributed applications"
-HOMEPAGE="https://hpx.stellar-group.org/"
-
-SLOT="0"
-LICENSE="Boost-1.0"
-IUSE="examples jemalloc mpi papi +perftools tbb zlib"
-# tests fail to compile
-RESTRICT="test"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- ?? ( jemalloc perftools tbb )
-"
-
-BDEPEND="
- virtual/pkgconfig
-"
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-cpp/asio-1.12.0
- dev-libs/boost:=
- sys-apps/hwloc:=
- jemalloc? ( dev-libs/jemalloc:= )
- mpi? ( virtual/mpi )
- papi? ( dev-libs/papi )
- perftools? ( dev-util/google-perftools:= )
- tbb? ( dev-cpp/tbb:= )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.8.0-python.patch"
-)
-
-hpx_memory_requirement() {
- # HPX needs enough main memory for compiling
- # rule of thumb: 1G per job
- if [[ -z ${MAKEOPTS} ]] ; then
- echo "2G"
- else
- local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
- echo "${jobs}G"
- fi
-}
-
-pkg_pretend() {
- local CHECKREQS_MEMORY=$(hpx_memory_requirement)
- check-reqs_pkg_setup
-}
-
-pkg_setup() {
- local CHECKREQS_MEMORY=$(hpx_memory_requirement)
- check-reqs_pkg_setup
- python-single-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DHPX_WITH_EXAMPLES=OFF
- -DHPX_WITH_DOCUMENTATION=OFF
- -DHPX_WITH_PARCELPORT_MPI=$(usex mpi)
- -DHPX_WITH_PAPI=$(usex papi)
- -DHPX_WITH_GOOGLE_PERFTOOLS=$(usex perftools)
- -DHPX_WITH_COMPRESSION_ZLIB=$(usex zlib)
- -DHPX_WITH_TESTS=OFF
- )
- if use jemalloc; then
- mycmakeargs+=( -DHPX_WITH_MALLOC=jemalloc )
- elif use perftools; then
- mycmakeargs+=( -DHPX_WITH_MALLOC=tcmalloc )
- elif use tbb; then
- mycmakeargs+=( -DHPX_WITH_MALLOC=tbbmalloc )
- else
- mycmakeargs+=( -DHPX_WITH_MALLOC=system )
- fi
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-}
-
-src_install() {
- cmake_src_install
- use examples && dodoc -r examples/
- python_fix_shebang "${ED}"
-}