summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2019-07-16 23:50:38 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-18 09:58:31 +0200
commitd9410e9ab65866de556b845fe4837568d86637e1 (patch)
tree77ec401dad5dc7de64d0ceb3ccc03c7e26277331 /sys-cluster
parentdev-python/flask-paginate: verbump to 0.5.3 (diff)
downloadgentoo-d9410e9ab65866de556b845fe4837568d86637e1.tar.gz
gentoo-d9410e9ab65866de556b845fe4837568d86637e1.tar.bz2
gentoo-d9410e9ab65866de556b845fe4837568d86637e1.zip
sys-cluster/charliecloud: Version bump to 0.10
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.10.ebuild59
-rw-r--r--sys-cluster/charliecloud/files/charliecloud-0.10-fix-hardcoded-gcc.patch45
3 files changed, 105 insertions, 0 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index 78d4915c65c7..80b5b98868be 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,2 +1,3 @@
+DIST charliecloud-0.10.tar.gz 301083 BLAKE2B be0c650bebc12fd047b1afc61588b4b9cfc0d0addfddb808765d8e125c70329d6c06a86144b4167e5abaf64392ad1891319aabd2ba8fb528de2d9789d040fc0c SHA512 681e2f30f730b42b55b4097dba78e41924b17990354b866e04e09e6d2e4bb584211c130f9a04619dcdd38f2a3eaaad7615ee5ec20a266ee2332b0a512492331f
DIST charliecloud-0.9.10.tar.gz 275687 BLAKE2B e03c3358dd4e5eb88f9c5a3002366c79563e15d5d7792dd55f2800a001b847c13443fce0689a850aa7e6a0aa510c3f6b53d93a88a6f79326eac27acc9cbe2c57 SHA512 93a6f0c6bcceb54fabbc179b960a0d03f1b3547786ce8d502552ddc571475ea2110d6aa290ce5c245be6e2c7cdc47d3f23ff7e74558f684b4a27358aa0971a61
DIST charliecloud-0.9.6.tar.gz 205380 BLAKE2B 2e95f5486ea6d2306512378290cd29114bc688717741436ae9cc8c1dd2679c22ab21059574d62222cd14063bacecc6a7005b216cd9e2ed01fe1593a3b69871b0 SHA512 55af3e57ef6c2b81ae10bd50d149872af50d508392b271bdaa75cf3b655659ec7da5016a9deeea15aaa20e265e8066d1ed982c122cb5e62ee6d47f25d367410f
diff --git a/sys-cluster/charliecloud/charliecloud-0.10.ebuild b/sys-cluster/charliecloud/charliecloud-0.10.ebuild
new file mode 100644
index 000000000000..fdf652c5e31a
--- /dev/null
+++ b/sys-cluster/charliecloud/charliecloud-0.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
+HOMEPAGE="https://hpc.github.io/charliecloud/"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+IUSE="doc examples +pv"
+
+# Extensive test suite exists, but downloads container images
+# directly and via Docker and installs packages inside using apt/yum.
+# Additionally, clashes with portage namespacing and sandbox.
+RESTRICT="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ pv? ( sys-apps/pv )
+"
+DEPEND="doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ net-misc/rsync
+ )"
+
+PATCHES=(
+ # See upstream bug: https://github.com/hpc/charliecloud/pull/481/
+ "${FILESDIR}"/"${PN}-${PV}"-fix-hardcoded-gcc.patch
+)
+
+src_compile() {
+ emake
+ use doc && emake -C doc-src
+}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" DOCDIR="${ED}/usr/share/doc/${PF}" LIBEXEC_DIR="libexec/${PF}"
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ einstalldocs
+}
diff --git a/sys-cluster/charliecloud/files/charliecloud-0.10-fix-hardcoded-gcc.patch b/sys-cluster/charliecloud/files/charliecloud-0.10-fix-hardcoded-gcc.patch
new file mode 100644
index 000000000000..07e72b2fbd3e
--- /dev/null
+++ b/sys-cluster/charliecloud/files/charliecloud-0.10-fix-hardcoded-gcc.patch
@@ -0,0 +1,45 @@
+From bae9f01ed5ad0ef5d6c0b48cbc1a7fde73ae45ae Mon Sep 17 00:00:00 2001
+From: Oliver Freyermuth <o.freyermuth@googlemail.com>
+Date: Mon, 15 Jul 2019 18:36:24 +0200
+Subject: [PATCH] test/Makefile: Remove hardcoded call to gcc, error out if
+ CC=icc.
+
+---
+ test/Makefile | 13 +++++++++----
+ 1 file changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/test/Makefile b/test/Makefile
+index 97a9316b..7c28ce2a 100644
+--- a/test/Makefile
++++ b/test/Makefile
+@@ -10,7 +10,7 @@ images_eg := $(sort $(wildcard ../examples/*/*/Build)) \
+ $(sort $(wildcard ../examples/*/*/Docker_Pull)) \
+ $(sort $(wildcard ../examples/*/*/Docker_Pull.*))
+ images := $(images_ch) $(images_eg)
+-sotests := sotest/bin/sotest sotest/lib/libsotest.so.1.0
++sotests := check-no-icc sotest/bin/sotest sotest/lib/libsotest.so.1.0
+
+ # Favor embedded Bats, if installed, over system Bats.
+ export PATH := $(CURDIR)/bats/bin:$(PATH)
+@@ -76,13 +76,18 @@ sotest/bin/sotest: sotest/sotest
+ sotest/lib/libsotest.so.1.0: sotest/libsotest.so.1.0
+ cp -a $^ $@
+
+-# We hardcode gcc here because some other compilers (hello, Intel) link the
++# We exclude icc here because it links the
+ # resulting binaries with extra shared libraries that are then not copied into
+ # the container. (Issue #227.)
+
++check-no-icc:
++ifeq ($(patsubst %icc,,$(lastword $(CC))),)
++ $(error ICC not supported since it overlinks extra shared libraries)
++endif
++
+ sotest/sotest: sotest/sotest.c sotest/libsotest.so.1.0
+- gcc -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -L./sotest -lsotest $^
++ $(CC) -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -L./sotest -lsotest $^
+ sotest/libsotest.so.1.0: sotest/libsotest.c
+- gcc -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fPIC -Wl,-soname,libsotest.so.1 -lc $^
++ $(CC) -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fPIC -Wl,-soname,libsotest.so.1 -lc $^
+ ln -f -s libsotest.so.1.0 sotest/libsotest.so
+ ln -f -s libsotest.so.1.0 sotest/libsotest.so.1