summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:14:39 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:29 +0000
commite296bca1e7c776f65b62a5288f9074769471767b (patch)
treeff3b66a6d024510ea2ef3e8aaccdb4773d2cde3d /sys-cluster
parentsys-apps/pcsc-slb-rf72-drv: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-e296bca1e7c776f65b62a5288f9074769471767b.tar.gz
gentoo-e296bca1e7c776f65b62a5288f9074769471767b.tar.bz2
gentoo-e296bca1e7c776f65b62a5288f9074769471767b.zip
sys-cluster/ipvsadm: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ipvsadm/ipvsadm-1.27-r1.ebuild6
-rw-r--r--sys-cluster/ipvsadm/ipvsadm-1.28.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/sys-cluster/ipvsadm/ipvsadm-1.27-r1.ebuild b/sys-cluster/ipvsadm/ipvsadm-1.27-r1.ebuild
index a9729a137dea..b37bfb8058ed 100644
--- a/sys-cluster/ipvsadm/ipvsadm-1.27-r1.ebuild
+++ b/sys-cluster/ipvsadm/ipvsadm-1.27-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -39,7 +39,7 @@ src_prepare() {
src_compile() {
local libnl_include
if has_version ">=dev-libs/libnl-3.0"; then
- libnl_include=$(pkg-config --cflags libnl-3.0)
+ libnl_include=$($(tc-getPKG_CONFIG) --cflags libnl-3.0)
else
libnl_include=""
fi
@@ -48,7 +48,7 @@ src_compile() {
CC="$(tc-getCC)" \
HAVE_NL=1 \
STATIC=${STATIC} \
- POPT_LIB="$(pkg-config --libs popt)"
+ POPT_LIB="$($(tc-getPKG_CONFIG) --libs popt)"
}
src_install() {
diff --git a/sys-cluster/ipvsadm/ipvsadm-1.28.ebuild b/sys-cluster/ipvsadm/ipvsadm-1.28.ebuild
index 39f351f5ae90..ed048c1f31b9 100644
--- a/sys-cluster/ipvsadm/ipvsadm-1.28.ebuild
+++ b/sys-cluster/ipvsadm/ipvsadm-1.28.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -37,7 +37,7 @@ src_prepare() {
src_compile() {
local libnl_include
if has_version ">=dev-libs/libnl-3.0"; then
- libnl_include=$(pkg-config --cflags libnl-3.0)
+ libnl_include=$($(tc-getPKG_CONFIG) --cflags libnl-3.0)
else
libnl_include=""
fi
@@ -46,7 +46,7 @@ src_compile() {
CC="$(tc-getCC)" \
HAVE_NL=1 \
STATIC=${STATIC} \
- POPT_LIB="$(pkg-config --libs popt)"
+ POPT_LIB="$($(tc-getPKG_CONFIG)--libs popt)"
}
src_install() {