summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-03-27 12:45:02 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-28 16:21:17 +0200
commiteb059b0f66712f66d35afe148aa14941b61926a4 (patch)
tree7331023972ee87d36b82db87aaafbd4c01e439f9 /sys-cluster
parentsys-cluster/hpx: Drop old (diff)
downloadgentoo-eb059b0f66712f66d35afe148aa14941b61926a4.tar.gz
gentoo-eb059b0f66712f66d35afe148aa14941b61926a4.tar.bz2
gentoo-eb059b0f66712f66d35afe148aa14941b61926a4.zip
sys-cluster/hpx: Add MPI support
hpx supports MPI as well. Add support for it. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/hpx/hpx-1.4.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-cluster/hpx/hpx-1.4.1.ebuild b/sys-cluster/hpx/hpx-1.4.1.ebuild
index dd34133656ee..9a3dc2abc763 100644
--- a/sys-cluster/hpx/hpx-1.4.1.ebuild
+++ b/sys-cluster/hpx/hpx-1.4.1.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
SLOT="0"
LICENSE="Boost-1.0"
-IUSE="doc examples jemalloc papi +perftools tbb test"
+IUSE="doc examples jemalloc mpi papi +perftools tbb test"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -45,6 +45,7 @@ RDEPEND="
dev-libs/boost:=
sys-apps/hwloc
sys-libs/zlib
+ mpi? ( virtual/mpi )
papi? ( dev-libs/papi )
perftools? ( dev-util/google-perftools )
tbb? ( dev-cpp/tbb )
@@ -83,6 +84,7 @@ src_configure() {
local mycmakeargs=(
-DHPX_WITH_EXAMPLES=OFF
-DHPX_WITH_DOCUMENTATION=$(usex doc)
+ -DHPX_WITH_PARCELPORT_MPI=$(usex mpi)
-DHPX_WITH_PAPI=$(usex papi)
-DHPX_WITH_GOOGLE_PERFTOOLS=$(usex perftools)
-DBUILD_TESTING=$(usex test)