summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-03-01 02:01:22 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-03-01 02:02:07 +0100
commitcfaa5ec192519a74951fd57f05c483984e408e4b (patch)
tree4767374a0165f7e7b443ae8512b3d48f93061bf0 /sys-devel/automake/automake-1.10.3-r3.ebuild
parentdev-db/mariadb: Fix building with abi_x86_32 and -server USE (diff)
downloadgentoo-cfaa5ec192519a74951fd57f05c483984e408e4b.tar.gz
gentoo-cfaa5ec192519a74951fd57f05c483984e408e4b.tar.bz2
gentoo-cfaa5ec192519a74951fd57f05c483984e408e4b.zip
sys-devel/automake: Rev bump to remove Python 2.7 dependency for FEATURES=-test
Reported-by: Francesco Riosa <vivo75@gmail.com> Closes: https://bugs.gentoo.org/648940 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-devel/automake/automake-1.10.3-r3.ebuild')
-rw-r--r--sys-devel/automake/automake-1.10.3-r3.ebuild95
1 files changed, 0 insertions, 95 deletions
diff --git a/sys-devel/automake/automake-1.10.3-r3.ebuild b/sys-devel/automake/automake-1.10.3-r3.ebuild
deleted file mode 100644
index 7ce1045c9103..000000000000
--- a/sys-devel/automake/automake-1.10.3-r3.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-any-r1
-
-DESCRIPTION="Used to generate Makefile.in from Makefile.am"
-HOMEPAGE="https://www.gnu.org/software/automake/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-# Use Gentoo versioning for slotting.
-SLOT="${PV:0:4}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="test"
-
-RDEPEND="dev-lang/perl
- >=sys-devel/automake-wrapper-10
- >=sys-devel/autoconf-2.69:*
- sys-devel/gnuconfig"
-DEPEND="${RDEPEND}
- sys-apps/help2man
- test? ( ${PYTHON_DEPS} )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.10-perl-5.16.patch #424453
- "${FILESDIR}"/${PN}-1.11-install-sh-avoid-low-risk-race-in-tmp.patch
- "${FILESDIR}"/${PN}-1.13-perl-escape-curly-bracket-r1.patch
-)
-
-src_prepare() {
- default
- export WANT_AUTOCONF=2.5
- chmod a+rx tests/*.test
-}
-
-src_configure() {
- econf --docdir="\$(datarootdir)/doc/${PF}"
-}
-
-# slot the info pages. do this w/out munging the source so we don't have
-# to depend on texinfo to regen things. #464146 (among others)
-slot_info_pages() {
- pushd "${ED%/}"/usr/share/info >/dev/null || die
- rm -f dir || die
-
- # Rewrite all the references to other pages.
- # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
- # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
- local p pages=( *.info ) args=()
- for p in "${pages[@]/%.info}" ; do
- args+=(
- -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
- -e "s:(${p}):(${p}-${SLOT}):g"
- )
- done
- sed -i "${args[@]}" * || die
-
- # Rewrite all the file references, and rename them in the process.
- local f d
- for f in * ; do
- d=${f/.info/-${SLOT}.info}
- mv "${f}" "${d}" || die
- sed -i -e "s:${f}:${d}:g" * || die
- done
-
- popd >/dev/null || die
-}
-
-src_test() {
- python_setup
-
- default
-}
-
-src_install() {
- default
- slot_info_pages
-
- # SLOT the docs and junk
- local x
- for x in aclocal automake ; do
- help2man "perl -Ilib ${x}" > ${x}-${SLOT}.1
- doman ${x}-${SLOT}.1
- rm -f "${ED%/}"/usr/bin/${x}
- done
-
- # remove all config.guess and config.sub files replacing them
- # w/a symlink to a specific gnuconfig version
- for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
- done
-}