summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-11-08 10:38:59 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-11-08 10:47:44 +0100
commit5b3feae07252c3445c9740a2a8fb418689844d22 (patch)
treed638139381adf14f55c8a94a6add5b31266232fa /sys-devel/automake/automake-9999.ebuild
parentnet-wireless/blueman: Call eautomake to replace py-compile (diff)
downloadgentoo-5b3feae07252c3445c9740a2a8fb418689844d22.tar.gz
gentoo-5b3feae07252c3445c9740a2a8fb418689844d22.tar.bz2
gentoo-5b3feae07252c3445c9740a2a8fb418689844d22.zip
sys-devel/automake: EAPI-7 bumps
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/automake/automake-9999.ebuild')
-rw-r--r--sys-devel/automake/automake-9999.ebuild38
1 files changed, 24 insertions, 14 deletions
diff --git a/sys-devel/automake/automake-9999.ebuild b/sys-devel/automake/automake-9999.ebuild
index 6932450d2cc3..9490f85d527a 100644
--- a/sys-devel/automake/automake-9999.ebuild
+++ b/sys-devel/automake/automake-9999.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit python-any-r1 versionator
+inherit python-any-r1
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.savannah.gnu.org/r/${PN}.git"
inherit git-r3
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
if [[ ${PV/_beta} == ${PV} ]]; then
- MY_P=${P}
+ MY_P="${P}"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
https://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
else
- MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
+ MY_PV="$(ver_cut 1).$(($(ver_cut 2)-1))b"
MY_P="${PN}-${MY_PV}"
# Alpha/beta releases are not distributed on the usual mirrors.
@@ -39,9 +39,12 @@ RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-11
>=sys-devel/autoconf-2.69:*
sys-devel/gnuconfig"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/gzip
sys-apps/help2man
- test? ( ${PYTHON_DEPS} )"
+ test? ( ${PYTHON_DEPS} )
+"
pkg_setup() {
use test && python-any-r1_pkg_setup
@@ -64,8 +67,8 @@ src_prepare() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${ED%/}"/usr/share/info >/dev/null || die
- rm -f dir || die
+ pushd "${ED}"/usr/share/info >/dev/null || die
+ rm dir || die
# Rewrite all the references to other pages.
# before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
@@ -94,16 +97,23 @@ src_install() {
default
slot_info_pages
- rm "${ED%/}"/usr/share/aclocal/README || die
- rmdir "${ED%/}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
rm \
- "${ED%/}"/usr/bin/{aclocal,automake} \
- "${ED%/}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
local x
for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ dosym ../gnuconfig/config.${x} \
+ /usr/share/${PN}-${SLOT}/config.${x}
done
+
+ # Avoid QA message about pre-compressed file in docs
+ local tarfile=""${ED}"/usr/share/doc/${PF}/amhello-1.0.tar.gz"
+ if [[ -f "${tarfile}" ]] ; then
+ gunzip "${tarfile}" || die
+ fi
}