summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-12-30 17:47:19 -0500
committerMike Gilbert <floppym@gentoo.org>2017-12-30 17:49:55 -0500
commitc9c48c989410c9aaf6e2cb6b0a51e6551fc97f29 (patch)
tree9d33d443197f6c74857dada8a226b625dadea82f /sys-devel/binutils-config/binutils-config-5-r4.ebuild
parentmedia-gfx/fontforge: fix misaligned memory access (diff)
downloadgentoo-c9c48c989410c9aaf6e2cb6b0a51e6551fc97f29.tar.gz
gentoo-c9c48c989410c9aaf6e2cb6b0a51e6551fc97f29.tar.bz2
gentoo-c9c48c989410c9aaf6e2cb6b0a51e6551fc97f29.zip
Revert "sys-devel/binutils-config: add avr/msp symlink handling"
This reverts commit 1b129b82462191f6adf022a2327d5b3a72dcb893. This change caused symlinks to go missing under /usr/${CTARGET}/lib for "normal" cross toolchains. Anothoer solution is needed for avr/msp. Closes: https://bugs.gentoo.org/642738
Diffstat (limited to 'sys-devel/binutils-config/binutils-config-5-r4.ebuild')
-rw-r--r--sys-devel/binutils-config/binutils-config-5-r4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-devel/binutils-config/binutils-config-5-r4.ebuild b/sys-devel/binutils-config/binutils-config-5-r4.ebuild
new file mode 100644
index 000000000000..6a486bdebf46
--- /dev/null
+++ b/sys-devel/binutils-config/binutils-config-5-r4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit prefix
+
+DESCRIPTION="Utility to change the binutils version being used"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+# We also RDEPEND on sys-apps/findutils which is in base @system
+RDEPEND="sys-apps/gentoo-functions
+ !<app-admin/eselect-1.4.5"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin "${FILESDIR}"/${PN}-${PV} ${PN}
+ use prefix && eprefixify "${ED}"/usr/bin/${PN}
+ sed -i "s:@PV@:${PVR}:g" "${ED}"/usr/bin/${PN} || die
+ doman "${FILESDIR}"/${PN}.8
+
+ insinto /usr/share/eselect/modules
+ doins "${FILESDIR}"/binutils.eselect
+}
+
+pkg_preinst() {
+ # Force a refresh when upgrading from an older version that symlinked
+ # in all the libs & includes that binutils-libs handles. #528088
+ if has_version "<${CATEGORY}/${PN}-5" ; then
+ local bc current
+ bc="${ED}/usr/bin/binutils-config"
+ if current=$("${bc}" -c) ; then
+ "${bc}" "${current}"
+ fi
+ fi
+}