summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-10-16 15:40:49 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-10-16 15:46:46 +0200
commit8db0876c9d6bb37167eb561445fe08e694b423e3 (patch)
treeb30005baae3694fbbfada9b9420dfc85deffdf00 /sys-devel/bison
parentdev-python/sphinx-multiversion: stabilize 0.2.4 on amd64 (diff)
downloadgentoo-8db0876c9d6bb37167eb561445fe08e694b423e3.tar.gz
gentoo-8db0876c9d6bb37167eb561445fe08e694b423e3.tar.bz2
gentoo-8db0876c9d6bb37167eb561445fe08e694b423e3.zip
sys-devel/bison: Bump to version 3.7.3
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/Manifest2
-rw-r--r--sys-devel/bison/bison-3.7.3.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index 8fe2ad7b3d57..8033295d6823 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -6,3 +6,5 @@ DIST bison-3.7.1-patches-01.tar.xz 11072 BLAKE2B e68dc42fdeebd9c530d04ba906fb49d
DIST bison-3.7.1.tar.xz 2605940 BLAKE2B a00e8af6a74100154d2dad1597c901f8473dbdcc57826eff947878c3568bfc9070d92857b3b3e349302e9fcfd67eb3287e7a04f6fcff3b897a6fecf43c1cd03d SHA512 9c4097b6ff26e819be14a9d4ef39f6f259c04627cd305e11da8e67897a369b2bba5ce96bf19fa5f6088670e90a9c5bc5c45172f8f482252aeec546b285dd0797
DIST bison-3.7.2-patches-02.tar.xz 99664 BLAKE2B 8f719265d16b42f398beef9ff9fde01c5f86d301421f64f8ac801cbc55af8d1258e1ae0f90e67b4de7bb8b25e99480acacc73815534f25e116f2f2b920ee9697 SHA512 bd99762a1f244755499efb400d2bb4399a5d21126eff253533b7f1320c8a4cd8513485cd176c90932029d720369182eb595ff36fa32ccaaa8d7048e46921e79b
DIST bison-3.7.2.tar.xz 2613404 BLAKE2B 7543c7df4496fbe6b9ab18ffb643a0d58eb63d0d1e91d67eaa6f9a7c805180c1cef02a640fd41eec228782a6758f82058dc4a45c13e3730b740883efad77498d SHA512 42eb501c246e9b4b24cb212c8da538b11b1944b997314105e67f88f22d73b7d00cf19b21e086aa7523630a2a24e1fd70a89d85a7e3003783990e08d31f711a27
+DIST bison-3.7.3-patches-01.tar.xz 11336 BLAKE2B 2648dacd99c64c366946dad34f9e5fd838b43257df47bf74e3a3b63b03099152b4884d9b1c5943ee5c47afb090369278874c5f2b40dfa69b3abfa4eaa556843f SHA512 a53d541a550cc45f6c677fb6fa830640b64ba2c9a4ab4e6aef1f52ecd5fa38501e2391707d66c2958dd7a139dfba74ae5734e80d15360a3aa544fdea8ecf5500
+DIST bison-3.7.3.tar.xz 2613028 BLAKE2B a6f1063fb9441ae9102b29dc2786b7eb7104f7f13288d537080c26e7982e63f7a954abf1903f2a79a88578d88e9f3c30da8dcf12b7d6c89de0b60943186332c7 SHA512 34fe630749dc015f15a830ad13742c4b0b9163143a11e987c16954bee0451e819ec2fa7b43bd34c867e5ce72c758eb9070348d1d581c9435b9531a99caa46eed
diff --git a/sys-devel/bison/bison-3.7.3.ebuild b/sys-devel/bison/bison-3.7.3.ebuild
new file mode 100644
index 000000000000..a123b190e3d0
--- /dev/null
+++ b/sys-devel/bison/bison-3.7.3.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+PATCH_TAR="${PN}-3.7.3-patches-01.tar.xz"
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="https://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ mirror://gentoo/${PATCH_TAR}
+ https://dev.gentoo.org/~whissi/dist/bison/${PATCH_TAR}
+ https://dev.gentoo.org/~polynomial-c/dist/bison/${PATCH_TAR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+RESTRICT="!test? ( test )
+ mirror"
+
+# gettext _IS_ required in RDEPEND because >=bison-3.7 links against
+# libtextstyle.so!!! (see bug #740754)
+DEPEND="
+ >=sys-devel/m4-1.4.16
+ >=sys-devel/gettext-0.21
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/flex
+ examples? ( dev-lang/perl )
+ test? ( dev-lang/perl )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO ) # ChangeLog-2012 ChangeLog-1998 PACKAGING README-alpha README-release
+
+src_prepare() {
+ # Record date to avoid 'config.status --recheck' & regen of 'tests/package.m4'
+ touch -r configure.ac old.configure.ac || die
+ touch -r configure old.configure || die
+
+ eapply "${WORKDIR}"/patches
+ default
+
+ # Restore date after patching
+ touch -r old.configure.ac configure.ac || die
+ touch -r old.configure configure || die
+
+ # The makefiles make the man page depend on the configure script
+ # which we patched above. Touch it to prevent regeneration.
+ touch doc/bison.1 || die #548778 #538300#9
+
+ # Avoid regenerating the info page when the timezone is diff. #574492
+ sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ $(use_enable examples)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED}"/usr/bin/yacc{,.bison} || die
+ mv "${ED}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED}"/usr/lib* || die
+}
+
+pkg_postinst() {
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}