summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-06-16 01:37:31 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-06-16 01:40:46 +0200
commitc60c074258cd1a41de05ad9adcecfd9f963318ea (patch)
tree3581aeebd5748439a7b5ad0e53f1077e802e7bfc /sys-devel/bison
parentdev-util/glslang: Fix RDEPEND (diff)
downloadgentoo-c60c074258cd1a41de05ad9adcecfd9f963318ea.tar.gz
gentoo-c60c074258cd1a41de05ad9adcecfd9f963318ea.tar.bz2
gentoo-c60c074258cd1a41de05ad9adcecfd9f963318ea.zip
sys-devel/bison: Bump to version 3.6.4
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/Manifest1
-rw-r--r--sys-devel/bison/bison-3.6.4.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index 224083a0d31a..3d83b2eb1a3a 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -10,3 +10,4 @@ DIST bison-3.6-patches-01.tar.xz 10140 BLAKE2B 7731f5ed15bd221f75a42961efa8a0343
DIST bison-3.6.2.tar.xz 2468224 BLAKE2B a2a6b0e110de3a18686b174928d3216a671111d1a38a99719d0796788fe34a1508af19a08bb090db2bd84a092be2d5511393399db12a5e856582499c9fe20b0b SHA512 69f5b6d9f28e0fe2d127a86e1315b06f3367c4d1cb667c0f0eee537fd5705d702d2a8db51204d7928db83efa83208cb5f738b27453eac6e2fd5037e8ffd0cd19
DIST bison-3.6.3-patches-01.tar.xz 10316 BLAKE2B a99e12e69334371316e5841f8c86ed716a9fed108800a33099e99f8fe432374259bf5477188d054b6d474bc905f821939691fc97f0c891d17a79968466f0c7e3 SHA512 5c97a183232ad31f231580193ed1853aba18010703b0c22105eaf6834241c9828d180eaafbc5d1da751b2d45a7e8195493e10ca2321b35680b2b3cd4ec39e3ca
DIST bison-3.6.3.tar.xz 2471436 BLAKE2B d0cb2b2e05096818f86c0212ef1c90ed7f6898e402e603a02e348b66305564121dde62fdba236e98054d7aca9daf6e9b3164c8885bc8c00d5577a4a3f7d7292c SHA512 8484fcc36f9767b0b5a90ca05e8cd956d38d7c8321038a3ce8b6c2dbf16852d816a03fe09025ad01072d64a2e46a2b42c803313a42e4e3dcc8d4ca6c7f960272
+DIST bison-3.6.4.tar.xz 2472456 BLAKE2B d2efe7ff1a349efe5a8c79eb69aa296dbc7eb9fde549afc91986460f27976e033dd793e904dda2f919f11e011ff6c458805288dff4939dcd1ee20e2b316cb9e6 SHA512 041cd87f4ca6b012031719a49aa81e62d3c0817c6364289732e6a3cb9a0762498760e0f2ce84c03ca9e9b74eb74bdffd1b8b86d2b4a6e4a0d8c8a4b864b672dc
diff --git a/sys-devel/bison/bison-3.6.4.ebuild b/sys-devel/bison/bison-3.6.4.ebuild
new file mode 100644
index 000000000000..fd0aba9c77d6
--- /dev/null
+++ b/sys-devel/bison/bison-3.6.4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+PATCHES="${PN}-3.6.3-patches-01.tar.xz"
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="https://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ mirror://gentoo/${PATCHES}
+ https://dev.gentoo.org/~whissi/dist/bison/${PATCHES}
+ https://dev.gentoo.org/~polynomial-c/dist/bison/${PATCHES}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ examples? ( dev-lang/perl )
+ nls? ( sys-devel/gettext )
+ test? ( dev-lang/perl )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO ) # ChangeLog-2012 ChangeLog-1998 PACKAGING README-alpha README-release
+
+PATCHES=(
+ "${WORKDIR}"/patches/${PN}-3.5-optional-perl.patch #538300
+ "${WORKDIR}"/patches/${PN}-3.6.3-avoid_autoreconf.patch
+)
+
+src_prepare() {
+ # Record date to avoid 'config.status --recheck' & regen of 'tests/package.m4'
+ touch -r configure.ac old.configure.ac || die
+ touch -r configure old.configure || die
+
+ default
+
+ # Restore date after patching
+ touch -r old.configure.ac configure.ac || die
+ touch -r old.configure configure || die
+
+ # The makefiles make the man page depend on the configure script
+ # which we patched above. Touch it to prevent regeneration.
+ touch doc/bison.1 || die #548778 #538300#9
+
+ # Avoid regenerating the info page when the timezone is diff. #574492
+ sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ $(use_enable examples)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED}"/usr/bin/yacc{,.bison} || die
+ mv "${ED}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED}"/usr/lib* || die
+}
+
+pkg_postinst() {
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}