summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-12 10:36:52 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-12 10:36:52 +0100
commit3f92f42f888fb0705c4679a089998a604bf2ca58 (patch)
tree975e0fc438a9c6021880d9ebfc8717d2c9c5667b /sys-devel/bmake
parentdev-python/flask-paginate: Fix maintainer order (diff)
downloadgentoo-3f92f42f888fb0705c4679a089998a604bf2ca58.tar.gz
gentoo-3f92f42f888fb0705c4679a089998a604bf2ca58.tar.bz2
gentoo-3f92f42f888fb0705c4679a089998a604bf2ca58.zip
sys-devel/bmake: Bump to 20201222
Closes: https://github.com/gentoo/gentoo/pull/18993 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-devel/bmake')
-rw-r--r--sys-devel/bmake/Manifest1
-rw-r--r--sys-devel/bmake/bmake-20201222.ebuild50
-rw-r--r--sys-devel/bmake/files/bmake-20201222-tests.patch26
3 files changed, 77 insertions, 0 deletions
diff --git a/sys-devel/bmake/Manifest b/sys-devel/bmake/Manifest
index 0d4c99a2030c..0e18157b7f7e 100644
--- a/sys-devel/bmake/Manifest
+++ b/sys-devel/bmake/Manifest
@@ -1,3 +1,4 @@
DIST bmake-20200318.tar.gz 572827 BLAKE2B f10c6f3e87497508e26154acb3e8a07b78daeba083228478023443b5ccaf540385c1d594fb968ed1fe9ccad30680e7c527db48fc3787c01930f62f88f1fb6699 SHA512 a405226e8f4a9a985ed00dc359390da7890d70f8a7b7e134db05da34ebc3c6ee2373497a9e44e0d75bb64edd81f860fd0cc204bdf7f392dd4e9d2e6a5fe9e507
DIST bmake-20201117.tar.gz 696371 BLAKE2B e92568e844d74f1ace157d68ea029c7a999351b18c3afab50ab584abb8c41691dee5fe4f2e1fd7936103cbbabe33dbbd6c7b2b0af2e0cc199dbb83150b237f8c SHA512 b78e6f6276032fe68a67196d18b6786556b1079109998b1c9a585a9d58e9245294ee01b3b787329a04e7f024fa72763c109351a8da9ec09f8bf8407393758588
+DIST bmake-20201222.tar.gz 727973 BLAKE2B cd093418c646e6b15e47f08c3c8e6a5daa5db2c9a1f76b4e8d639e0a50444ad518836585af7381bb2952309dd82716046a85e42121180133c9ccd546963a7748 SHA512 ddf1152adf99b350ae1ff1dd473319cd7c277c696f29b3ccba9080ecb9da0013f334b183c46a6e0a34708071a8f4f89d813264436e1946ebdc1923e6fe7440d9
DIST mk-20191111.tar.gz 102361 BLAKE2B 6a542c41e2a2153bd3c812aa9bcdc78a47bf2e9121835279afa2e57ec9cdd44f72a1cd7b48a7647d56b0586c547656f45359821cd2013c5a90532568e12086b5 SHA512 4a3e2344e7ada0666bcb147fcd4627030ba9b928acab6876215c8529b23909be4ced802bea177b078a6b4457370d2d0070114c0d69979622274be74336778861
diff --git a/sys-devel/bmake/bmake-20201222.ebuild b/sys-devel/bmake/bmake-20201222.ebuild
new file mode 100644
index 000000000000..547f81f91f68
--- /dev/null
+++ b/sys-devel/bmake/bmake-20201222.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MK_VER=20191111
+
+DESCRIPTION="NetBSD's portable make"
+HOMEPAGE="http://www.crufty.net/help/sjg/bmake.html"
+SRC_URI="
+ http://void.crufty.net/ftp/pub/sjg/${P}.tar.gz
+ http://void.crufty.net/ftp/pub/sjg/mk-${MK_VER}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${PN}"
+
+# Skip failing test (sandbox and csh)
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+
+src_configure() {
+ econf \
+ --with-mksrc=../mk \
+ --with-default-sys-path="${EPREFIX}"/usr/share/mk/${PN} \
+ --with-machine_arch=${ARCH}
+}
+
+src_compile() {
+ sh make-bootstrap.sh || die "bootstrap failed"
+}
+
+src_test() {
+ cd unit-tests || die
+
+ # the 'ternary' test uses ${A} internally, which
+ # conflicts with Gentoo's ${A}, hence unset it for
+ # the tests temporarily.
+ env -u A MAKEFLAGS= \
+ "${S}"/bmake -r -m / TEST_MAKE="${S}"/bmake test || die "tests compilation failed"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ FORCE_BSD_MK=1 SYS_MK_DIR=. \
+ sh ../mk/install-mk -v -m 644 "${ED}"/usr/share/mk/${PN} \
+ || die "failed to install mk files"
+}
diff --git a/sys-devel/bmake/files/bmake-20201222-tests.patch b/sys-devel/bmake/files/bmake-20201222-tests.patch
new file mode 100644
index 000000000000..9a5efb79246e
--- /dev/null
+++ b/sys-devel/bmake/files/bmake-20201222-tests.patch
@@ -0,0 +1,26 @@
+--- a/unit-tests/Makefile
++++ b/unit-tests/Makefile
+@@ -183,7 +183,6 @@ TESTS+= dotwait
+ TESTS+= envfirst
+ TESTS+= error
+ TESTS+= # escape # broken by reverting POSIX changes
+-TESTS+= export
+ TESTS+= export-all
+ TESTS+= export-env
+ TESTS+= export-variants
+@@ -280,7 +279,6 @@ TESTS+= sh-leading-plus
+ TESTS+= sh-meta-chars
+ TESTS+= sh-multi-line
+ TESTS+= sh-single-line
+-TESTS+= shell-csh
+ TESTS+= shell-custom
+ .if exists(/bin/ksh)
+ TESTS+= shell-ksh
+@@ -316,7 +314,6 @@ TESTS+= var-op-append
+ TESTS+= var-op-assign
+ TESTS+= var-op-default
+ TESTS+= var-op-expand
+-TESTS+= var-op-shell
+ TESTS+= var-op-sunsh
+ TESTS+= var-recursive
+ TESTS+= varcmd