summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-19 12:29:41 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-19 12:29:41 +0100
commit416b8105de0b7c56a9ef5eaa780b4dea18ca92d0 (patch)
tree4fe63e3a4cba2fc1cf5a080f63be7f7fff96d6f1 /sys-devel/bmake
parentdev-python/httplib2: Add missing pyparsing dep (diff)
downloadgentoo-416b8105de0b7c56a9ef5eaa780b4dea18ca92d0.tar.gz
gentoo-416b8105de0b7c56a9ef5eaa780b4dea18ca92d0.tar.bz2
gentoo-416b8105de0b7c56a9ef5eaa780b4dea18ca92d0.zip
sys-devel/bmake: Bump to 20210206
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-devel/bmake')
-rw-r--r--sys-devel/bmake/Manifest1
-rw-r--r--sys-devel/bmake/bmake-20210206.ebuild50
-rw-r--r--sys-devel/bmake/files/bmake-20210206-tests.patch18
3 files changed, 69 insertions, 0 deletions
diff --git a/sys-devel/bmake/Manifest b/sys-devel/bmake/Manifest
index 3fa6bb71fb4e..e5f2c33faaa4 100644
--- a/sys-devel/bmake/Manifest
+++ b/sys-devel/bmake/Manifest
@@ -1,4 +1,5 @@
DIST bmake-20200318.tar.gz 572827 BLAKE2B f10c6f3e87497508e26154acb3e8a07b78daeba083228478023443b5ccaf540385c1d594fb968ed1fe9ccad30680e7c527db48fc3787c01930f62f88f1fb6699 SHA512 a405226e8f4a9a985ed00dc359390da7890d70f8a7b7e134db05da34ebc3c6ee2373497a9e44e0d75bb64edd81f860fd0cc204bdf7f392dd4e9d2e6a5fe9e507
DIST bmake-20201117.tar.gz 696371 BLAKE2B e92568e844d74f1ace157d68ea029c7a999351b18c3afab50ab584abb8c41691dee5fe4f2e1fd7936103cbbabe33dbbd6c7b2b0af2e0cc199dbb83150b237f8c SHA512 b78e6f6276032fe68a67196d18b6786556b1079109998b1c9a585a9d58e9245294ee01b3b787329a04e7f024fa72763c109351a8da9ec09f8bf8407393758588
DIST bmake-20210110.tar.gz 735461 BLAKE2B e12882507bff3b47e4531519437e5e3c8fd0628edf8cbf7ca82b2e96745a767bead62f9a61bf3b99c1757803e29dfe757e0b2a48e2a2275a1ceaef1c63db9e24 SHA512 5b68b806a32a068e54d2a79796e99c189a6a5236c9596d5ebc9d0bbfa3454e975005c751a9e15eb077a8dc8e236630a900ecf5bee7674b3139d2b82a76c5a1e9
+DIST bmake-20210206.tar.gz 740065 BLAKE2B 2482b980ad4e4aac4292e0244020eeb3699148d84b0f493865a8317673eddb20ed48219f1319c490c6a88c6f1c50a44bd95af5de43f5853876bd10c1aef9b4bd SHA512 abda3aadd49abfe0e7801f4c37539a9172c3bb2d6ed542e0dec5b6177a799774a4b513041ff6167409c69ac6af35f506b1d6e585694259192a65a8575c232839
DIST mk-20191111.tar.gz 102361 BLAKE2B 6a542c41e2a2153bd3c812aa9bcdc78a47bf2e9121835279afa2e57ec9cdd44f72a1cd7b48a7647d56b0586c547656f45359821cd2013c5a90532568e12086b5 SHA512 4a3e2344e7ada0666bcb147fcd4627030ba9b928acab6876215c8529b23909be4ced802bea177b078a6b4457370d2d0070114c0d69979622274be74336778861
diff --git a/sys-devel/bmake/bmake-20210206.ebuild b/sys-devel/bmake/bmake-20210206.ebuild
new file mode 100644
index 000000000000..547f81f91f68
--- /dev/null
+++ b/sys-devel/bmake/bmake-20210206.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MK_VER=20191111
+
+DESCRIPTION="NetBSD's portable make"
+HOMEPAGE="http://www.crufty.net/help/sjg/bmake.html"
+SRC_URI="
+ http://void.crufty.net/ftp/pub/sjg/${P}.tar.gz
+ http://void.crufty.net/ftp/pub/sjg/mk-${MK_VER}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${PN}"
+
+# Skip failing test (sandbox and csh)
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+
+src_configure() {
+ econf \
+ --with-mksrc=../mk \
+ --with-default-sys-path="${EPREFIX}"/usr/share/mk/${PN} \
+ --with-machine_arch=${ARCH}
+}
+
+src_compile() {
+ sh make-bootstrap.sh || die "bootstrap failed"
+}
+
+src_test() {
+ cd unit-tests || die
+
+ # the 'ternary' test uses ${A} internally, which
+ # conflicts with Gentoo's ${A}, hence unset it for
+ # the tests temporarily.
+ env -u A MAKEFLAGS= \
+ "${S}"/bmake -r -m / TEST_MAKE="${S}"/bmake test || die "tests compilation failed"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ FORCE_BSD_MK=1 SYS_MK_DIR=. \
+ sh ../mk/install-mk -v -m 644 "${ED}"/usr/share/mk/${PN} \
+ || die "failed to install mk files"
+}
diff --git a/sys-devel/bmake/files/bmake-20210206-tests.patch b/sys-devel/bmake/files/bmake-20210206-tests.patch
new file mode 100644
index 000000000000..49e5f258e91a
--- /dev/null
+++ b/sys-devel/bmake/files/bmake-20210206-tests.patch
@@ -0,0 +1,18 @@
+--- a/unit-tests/Makefile
++++ b/unit-tests/Makefile
+@@ -191,7 +191,6 @@ TESTS+= dotwait
+ TESTS+= envfirst
+ TESTS+= error
+ TESTS+= # escape # broken by reverting POSIX changes
+-TESTS+= export
+ TESTS+= export-all
+ TESTS+= export-env
+ TESTS+= export-variants
+@@ -290,7 +289,6 @@ TESTS+= sh-leading-plus
+ TESTS+= sh-meta-chars
+ TESTS+= sh-multi-line
+ TESTS+= sh-single-line
+-TESTS+= shell-csh
+ TESTS+= shell-custom
+ .if exists(/bin/ksh)
+ TESTS+= shell-ksh