summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-12-21 11:38:22 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-21 11:46:11 +0100
commitaeb6907c6c414e87d38eeaf521cb7bdc9534e5f1 (patch)
treed4cd9c01dc078ce205d51301a06ba99d2cf3aee0 /sys-devel/bmake
parentsys-devel/bmake: fix manpage installation. (diff)
downloadgentoo-aeb6907c6c414e87d38eeaf521cb7bdc9534e5f1.tar.gz
gentoo-aeb6907c6c414e87d38eeaf521cb7bdc9534e5f1.tar.bz2
gentoo-aeb6907c6c414e87d38eeaf521cb7bdc9534e5f1.zip
sys-devel/bmake: clean up old from previous commit.
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-devel/bmake')
-rw-r--r--sys-devel/bmake/bmake-20160315-r1.ebuild55
-rw-r--r--sys-devel/bmake/bmake-20160606-r1.ebuild55
-rw-r--r--sys-devel/bmake/bmake-20160818-r1.ebuild55
3 files changed, 0 insertions, 165 deletions
diff --git a/sys-devel/bmake/bmake-20160315-r1.ebuild b/sys-devel/bmake/bmake-20160315-r1.ebuild
deleted file mode 100644
index bfc247267f22..000000000000
--- a/sys-devel/bmake/bmake-20160315-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils
-
-MK_VER=20151111
-DESCRIPTION="NetBSD's portable make"
-HOMEPAGE="http://www.crufty.net/help/sjg/bmake.html"
-SRC_URI="http://void.crufty.net/ftp/pub/sjg/${P}.tar.gz
- http://void.crufty.net/ftp/pub/sjg/mk-${MK_VER}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x64-freebsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${PN}"
-
-src_configure() {
- econf \
- --with-mksrc=../mk \
- --with-default-sys-path="${EPREFIX}"/usr/share/mk/${PN} \
- --with-machine_arch=${ARCH}
-}
-
-src_compile() {
- sh make-bootstrap.sh || die "bootstrap failed"
-}
-
-src_test() {
- cd unit-tests
- LC_ALL=C env -u A ${S}/bmake -r -m . > test.out 2>&1 \
- || die "tests compilation failed"
- sed -i \
- -e "s:${S}/::g" \
- -e "s:bmake\\[.\\]:make:g" \
- -e "s:unit-tests/::g" \
- test.out || die "Fixing values failed"
- diff -u test.exp test.out
- [[ $(diff -u test.exp test.out |wc -l) -gt 0 ]] && die "tests differ"
-}
-
-src_install() {
- dobin ${PN}
- doman ${PN}.1
- FORCE_BSD_MK=1 SYS_MK_DIR=. \
- sh ../mk/install-mk -v -m 644 "${ED}"/usr/share/mk/${PN} \
- || die "failed to install mk files"
-}
diff --git a/sys-devel/bmake/bmake-20160606-r1.ebuild b/sys-devel/bmake/bmake-20160606-r1.ebuild
deleted file mode 100644
index 0decbb3da166..000000000000
--- a/sys-devel/bmake/bmake-20160606-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils
-
-MK_VER=20151111
-DESCRIPTION="NetBSD's portable make"
-HOMEPAGE="http://www.crufty.net/help/sjg/bmake.html"
-SRC_URI="http://void.crufty.net/ftp/pub/sjg/${P}.tar.gz
- http://void.crufty.net/ftp/pub/sjg/mk-${MK_VER}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x64-freebsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${PN}"
-
-src_configure() {
- econf \
- --with-mksrc=../mk \
- --with-default-sys-path="${EPREFIX}"/usr/share/mk/${PN} \
- --with-machine_arch=${ARCH}
-}
-
-src_compile() {
- sh make-bootstrap.sh || die "bootstrap failed"
-}
-
-src_test() {
- cd unit-tests
- LC_ALL=C env -u A ${S}/bmake -r -m . > test.out 2>&1 \
- || die "tests compilation failed"
- sed -i \
- -e "s:${S}/::g" \
- -e "s:bmake\\[.\\]:make:g" \
- -e "s:unit-tests/::g" \
- test.out || die "Fixing values failed"
- diff -u test.exp test.out
- [[ $(diff -u test.exp test.out |wc -l) -gt 0 ]] && die "tests differ"
-}
-
-src_install() {
- dobin ${PN}
- doman ${PN}.1
- FORCE_BSD_MK=1 SYS_MK_DIR=. \
- sh ../mk/install-mk -v -m 644 "${ED}"/usr/share/mk/${PN} \
- || die "failed to install mk files"
-}
diff --git a/sys-devel/bmake/bmake-20160818-r1.ebuild b/sys-devel/bmake/bmake-20160818-r1.ebuild
deleted file mode 100644
index 0decbb3da166..000000000000
--- a/sys-devel/bmake/bmake-20160818-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils
-
-MK_VER=20151111
-DESCRIPTION="NetBSD's portable make"
-HOMEPAGE="http://www.crufty.net/help/sjg/bmake.html"
-SRC_URI="http://void.crufty.net/ftp/pub/sjg/${P}.tar.gz
- http://void.crufty.net/ftp/pub/sjg/mk-${MK_VER}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x64-freebsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${PN}"
-
-src_configure() {
- econf \
- --with-mksrc=../mk \
- --with-default-sys-path="${EPREFIX}"/usr/share/mk/${PN} \
- --with-machine_arch=${ARCH}
-}
-
-src_compile() {
- sh make-bootstrap.sh || die "bootstrap failed"
-}
-
-src_test() {
- cd unit-tests
- LC_ALL=C env -u A ${S}/bmake -r -m . > test.out 2>&1 \
- || die "tests compilation failed"
- sed -i \
- -e "s:${S}/::g" \
- -e "s:bmake\\[.\\]:make:g" \
- -e "s:unit-tests/::g" \
- test.out || die "Fixing values failed"
- diff -u test.exp test.out
- [[ $(diff -u test.exp test.out |wc -l) -gt 0 ]] && die "tests differ"
-}
-
-src_install() {
- dobin ${PN}
- doman ${PN}.1
- FORCE_BSD_MK=1 SYS_MK_DIR=. \
- sh ../mk/install-mk -v -m 644 "${ED}"/usr/share/mk/${PN} \
- || die "failed to install mk files"
-}