summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-15 20:36:20 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-15 20:41:35 +0200
commit5748c624d7a418a0a4bbe6e33bf27c5b9324f53a (patch)
treeb5526a34a16e250315745889f6b4a01a665e471b /sys-devel/clang-common
parentsys-devel/lld: Add 12.0.0.9999 for master branch (diff)
downloadgentoo-5748c624d7a418a0a4bbe6e33bf27c5b9324f53a.tar.gz
gentoo-5748c624d7a418a0a4bbe6e33bf27c5b9324f53a.tar.bz2
gentoo-5748c624d7a418a0a4bbe6e33bf27c5b9324f53a.zip
sys-devel/clang-common: Add 12.0.0.9999 for master branch
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/clang-common-12.0.0.9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-12.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-12.0.0.9999.ebuild
new file mode 100644
index 000000000000..18e41e0917da
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-12.0.0.9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}