summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-07 18:12:20 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-07 22:01:18 +0200
commit9203b12e1dfb48bb54bd18473fe192ab7d96b9dc (patch)
treec308270a89305b9ed1a85f264e52c42f094095ff /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 10.0.1-rc3 (diff)
downloadgentoo-9203b12e1dfb48bb54bd18473fe192ab7d96b9dc.tar.gz
gentoo-9203b12e1dfb48bb54bd18473fe192ab7d96b9dc.tar.bz2
gentoo-9203b12e1dfb48bb54bd18473fe192ab7d96b9dc.zip
sys-devel/clang-runtime: Bump to 10.0.1-rc3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-10.0.1_rc3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-10.0.1_rc3.ebuild b/sys-devel/clang-runtime/clang-runtime-10.0.1_rc3.ebuild
new file mode 100644
index 000000000000..65e66879ab98
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-10.0.1_rc3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"