summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-18 17:22:12 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-18 18:51:41 +0200
commit905d7440aed62f76289b2306479685bfc1040466 (patch)
treee67a1c66743067df28920586a55ca969dcbf15ca /sys-devel/clang/clang-10.0.1.ebuild
parentsys-kernel/gentoo-kernel-bin: Bump to 5.8.1 (diff)
downloadgentoo-905d7440aed62f76289b2306479685bfc1040466.tar.gz
gentoo-905d7440aed62f76289b2306479685bfc1040466.tar.bz2
gentoo-905d7440aed62f76289b2306479685bfc1040466.zip
sys-devel/clang: Add USE=default-lld
Closes: https://bugs.gentoo.org/737178 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang/clang-10.0.1.ebuild')
-rw-r--r--sys-devel/clang/clang-10.0.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-devel/clang/clang-10.0.1.ebuild b/sys-devel/clang/clang-10.0.1.ebuild
index d7adac061169..e50c60093b5a 100644
--- a/sys-devel/clang/clang-10.0.1.ebuild
+++ b/sys-devel/clang/clang-10.0.1.ebuild
@@ -30,8 +30,8 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA MIT"
SLOT="$(ver_cut 1)"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux"
-IUSE="debug default-compiler-rt default-libcxx doc +static-analyzer
- test xml kernel_FreeBSD ${ALL_LLVM_TARGETS[*]}"
+IUSE="debug default-compiler-rt default-libcxx default-lld doc
+ +static-analyzer test xml kernel_FreeBSD ${ALL_LLVM_TARGETS[*]}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( ${ALL_LLVM_TARGETS[*]} )"
RESTRICT="!test? ( test )"
@@ -53,7 +53,8 @@ PDEPEND="
sys-devel/clang-common
~sys-devel/clang-runtime-${PV}
default-compiler-rt? ( =sys-libs/compiler-rt-${PV%_*}* )
- default-libcxx? ( >=sys-libs/libcxx-${PV} )"
+ default-libcxx? ( >=sys-libs/libcxx-${PV} )
+ default-lld? ( sys-devel/lld )"
# Multilib notes:
# 1. ABI_* flags control ABIs libclang* is built for only.
@@ -247,6 +248,7 @@ multilib_src_configure() {
# override default stdlib and rtlib
-DCLANG_DEFAULT_CXX_STDLIB=$(usex default-libcxx libc++ "")
-DCLANG_DEFAULT_RTLIB=$(usex default-compiler-rt compiler-rt "")
+ -DCLANG_DEFAULT_LINKER=$(usex default-lld lld "")
-DCLANG_ENABLE_ARCMT=$(usex static-analyzer)
-DCLANG_ENABLE_STATIC_ANALYZER=$(usex static-analyzer)