summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-29 17:03:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-29 17:04:58 +0200
commitec2b13a11a6b5712817b20dab096a668f4afd06f (patch)
tree75e6269bd6cf2f5693ac721a4e26ab29f63f094d /sys-devel/clang/clang-11.0.0.9999.ebuild
parentsys-devel/llvm: Pass -Wl,--no-keep-memory to linker on x86 (diff)
downloadgentoo-ec2b13a11a6b5712817b20dab096a668f4afd06f.tar.gz
gentoo-ec2b13a11a6b5712817b20dab096a668f4afd06f.tar.bz2
gentoo-ec2b13a11a6b5712817b20dab096a668f4afd06f.zip
sys-devel/clang: Pass -Wl,--no-keep-memory to linker on x86
Closes: https://bugs.gentoo.org/712052 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang/clang-11.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang/clang-11.0.0.9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-11.0.0.9999.ebuild b/sys-devel/clang/clang-11.0.0.9999.ebuild
index 5991c42d4c69..76cb2b8d998e 100644
--- a/sys-devel/clang/clang-11.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-11.0.0.9999.ebuild
@@ -284,6 +284,10 @@ multilib_src_configure() {
)
fi
+ # LLVM can have very high memory consumption while linking,
+ # exhausting the limit on 32-bit linker executable
+ use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake_src_configure