summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-26 21:03:07 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-26 22:02:01 +0200
commit95b6a805b1a6d75413eeb60b2f83e53a21443d5e (patch)
tree32a2e86664ecc5ef14724300a34eae4803dfee1e /sys-devel/clang/clang-4.0.1.ebuild
parenttoolchain-glibc.eclass: remove special-casing of -freorder-blocks on ARCH=ppc (diff)
downloadgentoo-95b6a805b1a6d75413eeb60b2f83e53a21443d5e.tar.gz
gentoo-95b6a805b1a6d75413eeb60b2f83e53a21443d5e.tar.bz2
gentoo-95b6a805b1a6d75413eeb60b2f83e53a21443d5e.zip
sys-devel/clang: Disable extra tests w/o static-anal
Tests for clang-tools-extra are disabled upstream if static-analyzer is disabled. This is related to the fact that clang-tidy requires it, and upstream did not split the tests properly (yet). Bug: https://bugs.gentoo.org/627974
Diffstat (limited to 'sys-devel/clang/clang-4.0.1.ebuild')
-rw-r--r--sys-devel/clang/clang-4.0.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-devel/clang/clang-4.0.1.ebuild b/sys-devel/clang/clang-4.0.1.ebuild
index 821cae0ab5b8..91478e80294c 100644
--- a/sys-devel/clang/clang-4.0.1.ebuild
+++ b/sys-devel/clang/clang-4.0.1.ebuild
@@ -193,7 +193,11 @@ multilib_src_test() {
# respect TMPDIR!
local -x LIT_PRESERVES_TMP=1
cmake-utils_src_make check-clang
- multilib_is_native_abi && cmake-utils_src_make check-clang-tools
+ # clang-tidy requires [static-analyzer] and tests are not split
+ # correctly, so they are all disabled when static-analyzer is off
+ if multilib_is_native_abi && use static-analyzer; then
+ cmake-utils_src_make check-clang-tools
+ fi
}
src_install() {