summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin Tokarev <annulen@yandex.ru>2020-09-20 13:27:26 +0300
committerConrad Kostecki <conikost@gentoo.org>2020-09-22 23:13:49 +0200
commit1af86f6935d3a0417b3d083af91fb75ea9f3c91e (patch)
treebf0689a17be352a1c614613dea2061d234651d38 /sys-devel/dwz/dwz-0.13.ebuild
parentdev-python/voluptuous: Remove old (diff)
downloadgentoo-1af86f6935d3a0417b3d083af91fb75ea9f3c91e.tar.gz
gentoo-1af86f6935d3a0417b3d083af91fb75ea9f3c91e.tar.bz2
gentoo-1af86f6935d3a0417b3d083af91fb75ea9f3c91e.zip
sys-devel/dwz: Version update to 0.13
* Updated homepage URL * Updated SRC_URI: now dwz has proper tarball downloads * Added myself and proxy-maint project as maintainers * Removed empty variables IUSE and BDEPEND * Put set command in one line and dropped die message Closes: https://github.com/gentoo/gentoo/pull/17609 Signed-off-by: Konstantin Tokarev <annulen@yandex.ru> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-devel/dwz/dwz-0.13.ebuild')
-rw-r--r--sys-devel/dwz/dwz-0.13.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/dwz/dwz-0.13.ebuild b/sys-devel/dwz/dwz-0.13.ebuild
new file mode 100644
index 000000000000..a99b0d53e373
--- /dev/null
+++ b/sys-devel/dwz/dwz-0.13.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="DWARF optimization and duplicate removal tool"
+HOMEPAGE="https://sourceware.org/dwz"
+SRC_URI="https://sourceware.org/ftp/dwz/releases/${P}.tar.xz"
+
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/elfutils"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -e '/^CFLAGS/d' -i Makefile || die
+ tc-export CC
+}