summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-09-08 10:13:26 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-09-08 10:15:09 +0100
commitcc51dde0d07754dd5ce1155424d730274372739f (patch)
tree108e3ab4080290e7f5980eb4e4a4cb1e10bb7049 /sys-devel/gcc-config
parentpackage.mask: Last rite dev-db/vbisam, dev-lang/tinycobol (diff)
downloadgentoo-cc51dde0d07754dd5ce1155424d730274372739f.tar.gz
gentoo-cc51dde0d07754dd5ce1155424d730274372739f.tar.bz2
gentoo-cc51dde0d07754dd5ce1155424d730274372739f.zip
sys-devel/gcc-config: bump up to 2.1
- Don't cleanup /lib/libunwind.so (bug #667020) - Drop GCC_PATH reconstruction (bug #174422) - Use findmnt for mountpoint check when available (bug #693588) - drop /etc/env.d/gcc/.NATIVE symlink - drop /etc/env.d/gcc/config migration code - drop empty /etc/env.d/05gcc-${CTARGET} files - add einfo logging around library backup Bug: https://bugs.gentoo.org/667020 Bug: https://bugs.gentoo.org/174422 Bug: https://bugs.gentoo.org/693588 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/Manifest1
-rw-r--r--sys-devel/gcc-config/gcc-config-2.1.ebuild54
-rw-r--r--sys-devel/gcc-config/gcc-config-9999.ebuild4
3 files changed, 57 insertions, 2 deletions
diff --git a/sys-devel/gcc-config/Manifest b/sys-devel/gcc-config/Manifest
index e9a5d35b6358..500930b3cf17 100644
--- a/sys-devel/gcc-config/Manifest
+++ b/sys-devel/gcc-config/Manifest
@@ -1 +1,2 @@
DIST gcc-config-2.0.tar.xz 15344 BLAKE2B 323b1e791b831ee610a375fc03532ab89e31b1f74586742c1d37dcea9c7853cf4ebfef875fc2bfa273cfc1555a33b9f04a1e58c850133cddee765dd769bdb189 SHA512 67c8cfc7e031d4a88191c04495c97f46e90e2d3fce4cd1afc29f142fad9414218768d3c6de4bd8bb7d9baa39a20b17bb28a503b0d05d6db2003b767546317a30
+DIST gcc-config-2.1.tar.xz 15520 BLAKE2B 0e37762877116d90265a31cf6d9bc99da9b358afc26c0f7cb6fdbbb44dce23ebf59a1d5c2e481d456c03fbcc383efb7a56559af0bbd1f2bd78f407a853c88369 SHA512 0b19cb758a1e8c5e2e1f7901799fa1eb598d9d5c8d89ceace2e294ec569bfa90978bef72f52b9c2a3455f2ffd21be0899fb3e23b5fbdf62b70e978c153961272
diff --git a/sys-devel/gcc-config/gcc-config-2.1.ebuild b/sys-devel/gcc-config/gcc-config-2.1.ebuild
new file mode 100644
index 000000000000..fc7dbbda8a1d
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gcc-config.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="Utility to manage compilers"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gcc-config.git/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/gentoo-functions-0.10"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ PV="${PV}" \
+ SUBLIBDIR="$(get_libdir)"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PV="${PV}" \
+ SUBLIBDIR="$(get_libdir)" \
+ install
+}
+
+pkg_postinst() {
+ # Scrub eselect-compiler remains
+ rm -f "${ROOT}"/etc/env.d/05compiler &
+
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ rm -f "${ROOT}"/usr/include/g++{,-v3} &
+
+ # Do we have a valid multi ver setup ?
+ local x
+ for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
+ gcc-config ${x}
+ done
+
+ wait
+}
diff --git a/sys-devel/gcc-config/gcc-config-9999.ebuild b/sys-devel/gcc-config/gcc-config-9999.ebuild
index de2993cbb378..22370b52cc52 100644
--- a/sys-devel/gcc-config/gcc-config-9999.ebuild
+++ b/sys-devel/gcc-config/gcc-config-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs