summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-10-21 23:24:19 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-21 23:26:31 +0100
commit14a3cf5f5f9051617890a29748446e009b077aa8 (patch)
tree7cdfd747613e57627d874ee2116250917d8b7039 /sys-devel/gcc/gcc-3.3.6-r5.ebuild
parentdev-util/kdevelop-python: 5.4.3 version bump (diff)
downloadgentoo-14a3cf5f5f9051617890a29748446e009b077aa8.tar.gz
gentoo-14a3cf5f5f9051617890a29748446e009b077aa8.tar.bz2
gentoo-14a3cf5f5f9051617890a29748446e009b077aa8.zip
sys-devel/gcc: bump 3.3.6 up to EAPI=6
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-3.3.6-r5.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.3.6-r5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-3.3.6-r5.ebuild b/sys-devel/gcc/gcc-3.3.6-r5.ebuild
new file mode 100644
index 000000000000..ca341bf4a814
--- /dev/null
+++ b/sys-devel/gcc/gcc-3.3.6-r5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PATCH_VER="3"
+UCLIBC_VER="1.1"
+HTB_VER="1.00-r2"
+
+inherit eutils toolchain
+
+# ia64 - broken static handling; USE=static emerge busybox
+KEYWORDS="~amd64 ~x86"
+
+# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
+# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
+# well tested in gentoo on any arch other than amd64!!
+RDEPEND=">=sys-devel/binutils-2.14.90.0.6-r1"
+DEPEND="${RDEPEND}
+ amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
+
+src_prepare() {
+ toolchain_src_prepare
+
+ if [[ -n ${UCLIBC_VER} ]] && [[ ${CTARGET} == *-uclibc* ]] ; then
+ mv "${S}"/gcc-3.3.2/libstdc++-v3/config/os/uclibc "${S}"/libstdc++-v3/config/os/ || die
+ mv "${S}"/gcc-3.3.2/libstdc++-v3/config/locale/uclibc "${S}"/libstdc++-v3/config/locale/ || die
+ fi
+
+ # Anything useful and objc will require libffi. Seriously. Lets just force
+ # libffi to install with USE="objc", even though it normally only installs
+ # if you attempt to build gcj.
+ if use objc && ! use gcj ; then
+ epatch "${FILESDIR}"/3.3.4/libffi-without-libgcj.patch
+ #epatch "${FILESDIR}"/3.4.3/libffi-nogcj-lib-path-fix.patch
+ fi
+}