summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-11-09 23:43:32 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-11-09 23:43:32 +0000
commit18eeb260864c85eed39856f8c2b38f24e319a3d3 (patch)
tree07446c677d98648905c121ef692eb4780ddb1f69 /sys-devel/gcc/gcc-4.4.7-r3.ebuild
parentsys-devel/gcc: 4.3.6: cut 2 patchset (diff)
downloadgentoo-18eeb260864c85eed39856f8c2b38f24e319a3d3.tar.gz
gentoo-18eeb260864c85eed39856f8c2b38f24e319a3d3.tar.bz2
gentoo-18eeb260864c85eed39856f8c2b38f24e319a3d3.zip
sys-devel/gcc: 4.4.7: cut 2 patchset
Single patch update: 99_all_cgraph_node-gcc-9.patch: allow gcc-9.2 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-4.4.7-r3.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.4.7-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.4.7-r3.ebuild b/sys-devel/gcc/gcc-4.4.7-r3.ebuild
new file mode 100644
index 000000000000..75b290303ee9
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.4.7-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PATCH_VER="2"
+UCLIBC_VER="1.0"
+
+inherit eutils toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_prepare() {
+ toolchain_src_prepare
+ use vanilla && return 0
+
+ sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
+}