summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-06-01 10:11:02 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-06-01 11:10:31 +0100
commit3eb5a512f39dc2f7b2d53d5e4d5d525a1df53f66 (patch)
tree20d6dd65cc6521946399eed7be0cce12627258c4 /sys-devel/gcc/gcc-4.5.4-r2.ebuild
parentsys-devel/gcc: 4.6.4: cut 1.5 patchset (diff)
downloadgentoo-3eb5a512f39dc2f7b2d53d5e4d5d525a1df53f66.tar.gz
gentoo-3eb5a512f39dc2f7b2d53d5e4d5d525a1df53f66.tar.bz2
gentoo-3eb5a512f39dc2f7b2d53d5e4d5d525a1df53f66.zip
sys-devel/gcc: 4.5.4: cut 1.5 patchset
Three new patches: 101_all_libjava-ucontext.patch: fix libjava build on modern glibc 102_all_cgraph_node-gcc-9.patch: workaround buid failure against gcc-9.1.0 103_all_gcc-gperf-gnu-inline.patch: fix inline declaration for modern gcc Closes: https://bugs.gentoo.org/629502 Bug: https://gcc.gnu.org/PR90677 Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-4.5.4-r2.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.5.4-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.5.4-r2.ebuild b/sys-devel/gcc/gcc-4.5.4-r2.ebuild
new file mode 100644
index 000000000000..1102974a8408
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.5.4-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.5"
+UCLIBC_VER="1.0"
+
+inherit eutils toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_prepare() {
+ toolchain_src_prepare
+
+ use vanilla && return 0
+
+ sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
+}